summary refs log tree commit diff
path: root/gnu/packages/graphviz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 08:46:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 10:25:32 +0200
commit29ddbc5607c8ad7bb0622e10716e60396817a42d (patch)
treed50a97557484a7c8ccac9d9d36cd2c6365513451 /gnu/packages/graphviz.scm
parent1779aaa09a576401e35bf4a0d1534ee546b5506e (diff)
downloadguix-29ddbc5607c8ad7bb0622e10716e60396817a42d.tar.gz
gnu: python-pydot: Update to 1.2.4.
* gnu/packages/graphviz.scm (python-pydot): Update to 1.2.4.
[arguments]: Run the test suite.
[native-inputs]: Add python-chardet.
Diffstat (limited to 'gnu/packages/graphviz.scm')
-rw-r--r--gnu/packages/graphviz.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/graphviz.scm b/gnu/packages/graphviz.scm
index 09f46fab84..569923d4e0 100644
--- a/gnu/packages/graphviz.scm
+++ b/gnu/packages/graphviz.scm
@@ -220,17 +220,18 @@ be used either as a standalone application, or as a python library.")
 (define-public python-pydot
   (package
     (name "python-pydot")
-    (version "1.2.3")
+    (version "1.2.4")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pydot" version))
        (sha256
         (base32
-         "00imlz0033dygb9gdag1xr0cybn33gk5jsdi9ffbszzr97rd7dgd"))))
+         "1dhy4jpp646jslh2yks6klwwbaxcs905byyny880gl1iap8y5llj"))))
     (build-system python-build-system)
-    ;; FIXME: No tests in PyPi release tarball.
-    (arguments '(#:tests? #f))
+    (native-inputs
+     ;; For tests.
+     `(("python-chardet" ,python-chardet)))
     (propagated-inputs
      `(("python-pyparsing" ,python-pyparsing)))
     (home-page "https://github.com/erocarrera/pydot")