summary refs log tree commit diff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-06 19:46:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-07 11:59:04 +0200
commit0559a4c2ca5b2573d5086c8b64794a634fc3e799 (patch)
tree8dd482e6840e9c1377b48ea60bd9e22b3ffd2177 /gnu/packages/groff.scm
parentf478ff860545bcea474da96b4d7f7e8ac1602218 (diff)
downloadguix-0559a4c2ca5b2573d5086c8b64794a634fc3e799.tar.gz
gnu: groff: Update to 1.22.4.
* gnu/packages/groff.scm (groff): Update to 1.22.4.
[source]: Remove patch.
(groff-minimal)[arguments]: Update configure flags to skip documentation.
* gnu/packages/patches/groff-source-date-epoch.patch: Remove file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 77728a5d78..9bf8662b9f 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,14 +37,13 @@
 (define-public groff
   (package
    (name "groff")
-   (version "1.22.3")
+   (version "1.22.4")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/groff/groff-" version
                                 ".tar.gz"))
             (sha256 (base32
-                     "1998v2kcs288d3y7kfxpvl369nqi06zbbvjzafyvyl3pr7bajj1s"))
-            (patches (search-patches "groff-source-date-epoch.patch"))))
+                     "14q2mldnr1vx0l9lqp9v2f6iww24gj28iyh4j2211hyynx67p3p7"))))
    (build-system gnu-build-system)
    (outputs '("out"
               "doc"))                    ;12MiB of PS, PDF, HTML, and examples
@@ -91,7 +91,7 @@ is usually the formatter of \"man\" documentation pages.")
     (arguments
      `(#:disallowed-references (,perl)
 
-       #:configure-flags '("--docdir=/tmp/trash/doc")
+       #:configure-flags '("--with-doc=no")
 
        ,@(substitute-keyword-arguments (package-arguments groff)
            ((#:phases phases)