summary refs log tree commit diff
path: root/gnu/packages/groff.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-01-16 18:27:27 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-01-16 18:31:27 +0200
commit96733e941754759d4a1f45ef8fb05dc9ff6db7b3 (patch)
treec75b62a9dabe5dcb28aa9fe5304f0173ce7aca54 /gnu/packages/groff.scm
parent9a5091d0c181453d0f31ce97f96a4e577a25e796 (diff)
downloadguix-96733e941754759d4a1f45ef8fb05dc9ff6db7b3.tar.gz
Revert "gnu: groff: Disable relocatability."
This causes more than 3600 packages to be rebuilt.

This reverts commit f57693e17c7905d2f11e46d04cb558fe0b0fc39b.
Diffstat (limited to 'gnu/packages/groff.scm')
-rw-r--r--gnu/packages/groff.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 62e844e1ed..77728a5d78 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -62,34 +62,6 @@
     `(#:parallel-build? #f   ; parallel build fails
       #:phases
       (modify-phases %standard-phases
-        (add-after 'unpack 'disable-relocatability
-          (lambda _
-            ;; Groff contains a Rube Goldberg-esque relocator for the file
-            ;; "charset.alias".  It tries to find the current executable
-            ;; using realpath, a do-it-yourself search in $PATH and so on.
-            ;; Furthermore, the routine that does the search is buggy
-            ;; in that it doesn't handle error cases when they arise.
-            ;; This causes preconv to segfault when trying to look up
-            ;; the file "charset.alias" in the NULL location.
-            ;; The "charset.alias" parser is a copy of gnulib's, and a
-            ;; non-broken version of gnulib's "charset.alias" parser is
-            ;; part of glibc's libcharset.
-            ;; However, groff unconditionally uses their own
-            ;; "charset.alias" parser, but then DOES NOT INSTALL the
-            ;; file "charset.alias" when glibc is too new.
-            ;; In Guix, our file "charset.alias" only contains an obscure
-            ;; alias for ASCII and nothing else.  So just disable relocation
-            ;; and make the entire "charset.alias" lookup fail.
-            ;; See <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=30785> for
-            ;; details.
-            (substitute* "src/libs/libgroff/Makefile.sub"
-             (("-DENABLE_RELOCATABLE=1") ""))
-            ;; That file contains a crash bug--so make sure that
-            ;; its contents are not there.
-            (call-with-output-file "src/libs/libgroff/relocate.cpp"
-              (lambda (port)
-                #t))
-            #t))
         (add-after 'unpack 'setenv
           (lambda _
             (setenv "GS_GENERATE_UUIDS" "0")