summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-04-29 16:19:52 +0800
committer宋文武 <iyzsong@gmail.com>2015-04-29 16:19:52 +0800
commit27c4f0cc03448b53053fa33035bdfc5b17178a92 (patch)
treefaab38f95e0c04fe10c62cd39b807db2facd8726 /gnu/packages/gstreamer.scm
parent3ec4bba4c9b4098877dbaa2708b8f758afd05f2f (diff)
downloadguix-27c4f0cc03448b53053fa33035bdfc5b17178a92.tar.gz
gnu: Remove gstreamer-0.10 and gst-plugins-base-0.10.
* gnu/packages/gstreamer.scm (gstreamer-0.10, gst-plugins-base-0.10):
  Remove variables.
* gnu/packages/patches/gstreamer-0.10-bison3.patch,
  gnu/packages/patches/gstreamer-0.10-silly-test.patch: Remove files.
* gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b882208d76..03aecdfa53 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -124,32 +124,6 @@ simple plugin with a clean, generic interface.
 This package provides the core library and elements.")
     (license lgpl2.0+)))
 
-(define-public gstreamer-0.10
-  (package (inherit gstreamer)
-    (version "0.10.36")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "1nkid1n2l3rrlmq5qrf5yy06grrkwjh3yxl5g0w58w0pih8allci"))
-      (patches
-        (list (search-patch "gstreamer-0.10-bison3.patch")
-              (search-patch "gstreamer-0.10-silly-test.patch")))))
-    (propagated-inputs
-     `(("libxml2" ,libxml2)))
-    (inputs `(("glib" ,glib)))
-    (native-inputs
-     `(("bison" ,bison)
-       ("flex" ,flex)
-       ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("glib" ,glib "bin")
-       ("python" ,python-2)))))
-
-
 (define-public gst-plugins-base
   (package
     (name "gst-plugins-base")
@@ -288,23 +262,3 @@ developers consider to have good quality code and correct functionality.")
      "This GStreamer plugin supports a large number of audio and video
 compression formats through the use of the libav library.")
     (license gpl2+)))
-
-(define-public gst-plugins-base-0.10
-  (package (inherit gst-plugins-base)
-    (version "0.10.36")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append 
-            "http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-"
-            version ".tar.xz"))
-      (sha256
-       (base32
-        "0jp6hjlra98cnkal4n6bdmr577q8mcyp3c08s3a02c4hjhw5rr0z"))))
-    (inputs
-     `(("glib" ,glib)
-       ("gstreamer" ,gstreamer-0.10)))
-    (native-inputs
-      `(("pkg-config" ,pkg-config)
-        ("glib" ,glib "bin")
-        ("python" ,python-2)))))