summary refs log tree commit diff
path: root/gnu/packages/gstreamer.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-30 18:05:57 +0200
commit426adbe82731b8b4968cad8d474545d3e8b55c65 (patch)
tree5fbc7f62c5bfa2e3a97c01c7974d119cf6400824 /gnu/packages/gstreamer.scm
parent1ddbd9fd71502c9332ca84a74734121c407a5708 (diff)
downloadguix-426adbe82731b8b4968cad8d474545d3e8b55c65.tar.gz
gnu: glib: Add "bin" output.
Fixes <http://bugs.gnu.org/17853>.

* gnu/packages/glib.scm (glib)[outputs]: Add "bin".
  (gobject-introspection)[native-inputs]: New field.
* gnu/packages/avahi.scm (avahi)[native-inputs]: Add glib:bin.
* gnu/packages/gnome.scm (brasero, libgnome-keyring, evince,
  gsettings-desktop-schemas, libnotify, gtkglext): Likewise.
* gnu/packages/gstreamer.scm (gstreamer, gst-plugins-base,
  gst-plugins-base-0.10): Likewise.
* gnu/packages/gtk.scm (atk, pango, gdk-pixbuf, gtk+-2, gtk+):
  Likewise.
* gnu/packages/linux.scm (udev): Likewise.
* gnu/packages/pdf.scm (poppler): Likewise.
Diffstat (limited to 'gnu/packages/gstreamer.scm')
-rw-r--r--gnu/packages/gstreamer.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index c68d756d1e..6f6494d4d4 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -51,6 +51,7 @@
     (native-inputs
      `(("bison" ,bison)
        ("flex" ,flex)
+       ("glib" ,glib "bin")
        ("perl" ,perl)
        ("pkg-config" ,pkg-config)
        ("python-wrapper" ,python-wrapper)))
@@ -112,6 +113,7 @@ This package provides the core library and elements.")
        ("gstreamer" ,gstreamer)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
+        ("glib" ,glib "bin")
         ("python-wrapper" ,python-wrapper)))
     (arguments
      `(#:tests? #f))
@@ -154,4 +156,5 @@ This package provides an essential exemplary set of elements.")
        ("gstreamer" ,gstreamer-0.10)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
-       ("python" ,python-2)))))
+        ("glib" ,glib "bin")
+        ("python" ,python-2)))))