summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-10-01 16:21:21 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-10-02 11:00:04 +0000
commit1f7cf5834cdf8349a26c99c280e9514487526350 (patch)
tree408dc91e47cbc5cfae7d12c45b553e9e244c2132 /gnu/packages/gtk.scm
parentcf7c7e25960d05e0151d018aad62c5c5d8a2faa5 (diff)
downloadguix-1f7cf5834cdf8349a26c99c280e9514487526350.tar.gz
gnu: gdk-pixbuf: Respect #:tests?.
* gnu/packages/gtk.scm (gdk-pixbuf)[arguments]<#:phases>{check}: Don't
  run the tests if the value for #:tests? is false.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index fd7feab69b..bbef514dd7 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -646,8 +646,9 @@ highlighting and other features typical of a source code editor.")
          ,@(if (any (cute string=? <> (%current-system))
                     '("armhf-linux" "aarch64-linux"))
                '((replace 'check
-                   (lambda _
-                     (invoke "meson" "test" "--timeout-multiplier" "5"))))
+                   (lambda* (#:key tests? #:allow-other-keys)
+                     (when tests?
+                       (invoke "meson" "test" "--timeout-multiplier" "5")))))
                '()))))
     (propagated-inputs
      `( ;; Required by gdk-pixbuf-2.0.pc