summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorVivien Kraus <vivien@planete-kraus.eu>2023-11-14 12:10:25 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-12-19 23:49:23 +0100
commit5c43c2ddf3e34723a9b16fe6431f0bcd19fea7db (patch)
treeb49b2d1ef8b67dae1e64d97a3e49f4c366d613c4 /gnu/packages/gtk.scm
parent65edc32d529a628f074fece8195c10e3815570f6 (diff)
downloadguix-5c43c2ddf3e34723a9b16fe6431f0bcd19fea7db.tar.gz
gnu: gdk-pixbuf: Update to 2.42.10.
* gnu/packages/gtk.scm (gdk-pixbuf): Update to 2.42.10.
[#:configure-flags]: Add "-Dgtk_doc=true".
[native-inputs]: Remove docbook-xml-4.3, docbook-xml, libxml2 and libxslt. Add
gi-docgen and python-docutils.

Change-Id: I2375beadad7f5d606fa6d973694a10679e07b689
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9818746f58..063fb70c1c 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -691,7 +691,7 @@ highlighting and other features typical of a source code editor.")
 (define-public gdk-pixbuf
   (package
     (name "gdk-pixbuf")
-    (version "2.42.8")
+    (version "2.42.10")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"
@@ -699,12 +699,12 @@ highlighting and other features typical of a source code editor.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1iplb43nn74pp3w1wjwwn522i9man6jia85k6j8v4494rcxfmb44"))))
+                "0jz4kziz5lirnjjvbspbqzsigk8vnqknng1fga89d81vs5snr6zf"))))
     (build-system meson-build-system)
     (outputs '("out" "debug"))
     (arguments
      `(#:glib-or-gtk? #t             ; To wrap binaries and/or compile schemas
-       #:configure-flags '("-Dinstalled_tests=false")
+       #:configure-flags '("-Dinstalled_tests=false" "-Dgtk_doc=true")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'disable-failing-tests
@@ -741,10 +741,8 @@ highlighting and other features typical of a source code editor.")
            pkg-config
 
            ;; For the documentation.
-           docbook-xml-4.3
-           docbook-xsl
-           libxml2                      ;for XML_CATALOG_FILES
-           libxslt))                    ;for xsltproc
+           gi-docgen
+           python-docutils))
     (native-search-paths
      ;; This file is produced by the gdk-pixbuf-loaders-cache-file
      ;; profile hook.