summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 23:11:28 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-11-10 23:12:25 +0100
commit68d85de16383d054dbf4fb5da2437f9cc743e5d2 (patch)
tree9de6940de8f2f72318eee6782a91006864e1e2e3 /gnu/packages/gtk.scm
parente6974eae1d5d4111c789cf7cb347ba0658802c29 (diff)
downloadguix-68d85de16383d054dbf4fb5da2437f9cc743e5d2.tar.gz
gnu: gtksourceview-2: Propagate input libxml2.
* gnu/packages/gtk.scm (gtksourceview-2): Move libxml2 to propagated
  inputs.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index edfdb3fe7d..40eb8e49ed 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -293,7 +293,6 @@ diagrams.")
     (build-system gnu-build-system)
     (inputs
      `(("gtk" ,gtk+-2)
-       ("libxml2" ,libxml2)
        ;; These two are needed only to allow the tests to run successfully.
        ("xorg-server" ,xorg-server)
        ("shared-mime-info" ,shared-mime-info)))
@@ -301,6 +300,9 @@ diagrams.")
      `(("intltool" ,intltool)
        ("glib" ,glib "bin")             ; for glib-genmarshal, etc.
        ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     ;; As per the pkg-config file.
+     `(("libxml2" ,libxml2)))
     (arguments
      `(#:phases
        ;; Unfortunately, some of the tests in "make check" are highly dependent