summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-21 21:05:52 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-08-28 21:07:46 -0400
commit91a830d02894030dba1d2cbdaf2b3001df44c3b7 (patch)
tree965bf2d1976d32feba41d69feb28fd524f2f11a5 /gnu/packages/gtk.scm
parent9b2a3e023f7090d19c98e7582220340df3962555 (diff)
downloadguix-91a830d02894030dba1d2cbdaf2b3001df44c3b7.tar.gz
gnu: gtk+: Delete trailing #t and use iso-codes.
* gnu/packages/gtk.scm (gtk+)[inputs]: Replace iso-codes/official with
iso-codes.
[phases]: Delete trailing #t.
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 428273ee89..68d0b567e4 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -977,8 +977,8 @@ application suites.")
            fontconfig
            freetype
            (if (target-x86-64?)
-             librsvg
-             librsvg-2.40)
+               librsvg
+               librsvg-2.40)
            glib
            libcloudproviders-minimal
            libepoxy
@@ -998,11 +998,11 @@ application suites.")
            wayland
            wayland-protocols))
     (inputs
-     (list colord-minimal ;to prevent a cycle with inkscape
+     (list colord-minimal               ;to prevent a cycle with inkscape
            cups
            graphene
            harfbuzz
-           iso-codes/official ;XXX TODO core-updates: use iso-codes
+           iso-codes
            json-glib-minimal
            libxml2
            rest))
@@ -1059,8 +1059,7 @@ application suites.")
                 "tree-performance text children derive"))
              (substitute* "testsuite/reftests/Makefile.in"
                (("TEST_PROGS = gtk-reftest")
-                "TEST_PROGS = "))
-             #t))
+                "TEST_PROGS = "))))
          (add-before 'check 'pre-check
            (lambda _
              ;; Tests require a running X server.
@@ -1071,8 +1070,7 @@ application suites.")
              ;; Tests look for $XDG_RUNTIME_DIR.
              (setenv "XDG_RUNTIME_DIR" (getcwd))
              ;; For missing '/etc/machine-id'.
-             (setenv "DBUS_FATAL_WARNINGS" "0")
-             #t))
+             (setenv "DBUS_FATAL_WARNINGS" "0")))
          (add-after 'install 'move-desktop-files
            ;; Move desktop files into 'bin' to avoid cycle references.
            (lambda* (#:key outputs #:allow-other-keys)
@@ -1080,8 +1078,7 @@ application suites.")
                    (bin (assoc-ref outputs "bin")))
                (mkdir-p (string-append bin "/share"))
                (rename-file (string-append out "/share/applications")
-                            (string-append bin "/share/applications"))
-               #t))))))
+                            (string-append bin "/share/applications"))))))))
     (native-search-paths
      (list (search-path-specification
             (variable "GUIX_GTK3_PATH")