summary refs log tree commit diff
path: root/gnu/packages/gtk.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-10-23 10:40:27 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-23 13:11:27 +0300
commit9210ca9b0498d3360ee247841a6bd212d6aa8ec4 (patch)
tree3efe14c42c9ba29907035fa0a253324b2e52772e /gnu/packages/gtk.scm
parentdae956e7961ea4940a3823a7b33f8264196ca594 (diff)
downloadguix-9210ca9b0498d3360ee247841a6bd212d6aa8ec4.tar.gz
gnu: at-spi2-core: Skip tests on powerpc-linux.
* gnu/packages/gtk.scm (at-spi2-core)[arguments]: When building for
powerpc-linux skip the custom 'check phase.

Change-Id: I8c609c1cb6eb8b03746e294f7b8e3d0792c43443
Diffstat (limited to 'gnu/packages/gtk.scm')
-rw-r--r--gnu/packages/gtk.scm39
1 files changed, 23 insertions, 16 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 0d6df1f583..47d4c1808f 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -803,22 +803,29 @@ ever use this library.")
        #:phases
        #~(modify-phases %standard-phases
            (delete 'check)
-           (add-after 'install 'check
-             (lambda _
-               (setenv "HOME" (getenv "TMPDIR")) ;xfconfd requires a writable HOME
-               ;; Run test-suite under a dbus session.
-               (setenv "XDG_DATA_DIRS"  ;for finding org.xfce.Xfconf.service
-                       (string-append #$output "/share:" (getenv "XDG_DATA_DIRS")))
-               ;; Don't fail on missing  '/etc/machine-id'.
-               (setenv "DBUS_FATAL_WARNINGS" "0")
-               (with-directory-excursion (string-append "../at-spi2-core-"
-                                                        #$version "")
-                 (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
-                 (substitute* "ci/run-tests.sh"
-                   (("ps auxwww") "")   ;avoid a dependency on procps
-                   (("meson test -C _build")
-                    "meson test -C ../build")) ;adjust build directory
-                 (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))))
+           ;; The CI test suite fails completely on powerpc-linux.
+           ;; The name org.gnome.SessionManager was not provided by any .service
+           ;; TODO: Wrap 'check phase with 'tests?'.
+           #$@(if (not (target-ppc32?))
+                #~((add-after 'install 'check
+                     (lambda _
+                       ;; xfconfd requires a writable HOME
+                       (setenv "HOME" (getenv "TMPDIR"))
+                       ;; Run test-suite under a dbus session.
+                       (setenv "XDG_DATA_DIRS"  ;for finding org.xfce.Xfconf.service
+                               (string-append #$output "/share:"
+                                              (getenv "XDG_DATA_DIRS")))
+                       ;; Don't fail on missing  '/etc/machine-id'.
+                       (setenv "DBUS_FATAL_WARNINGS" "0")
+                       (with-directory-excursion (string-append "../at-spi2-core-"
+                                                                #$version "")
+                         (invoke "dbus-run-session" "--" "ci/run-registryd-tests.sh")
+                         (substitute* "ci/run-tests.sh"
+                           (("ps auxwww") "")   ;avoid a dependency on procps
+                           (("meson test -C _build")
+                            "meson test -C ../build")) ;adjust build directory
+                         (invoke "dbus-run-session" "--" "ci/run-tests.sh")))))
+                #~()))))
      (inputs
       (list bash-minimal libxml2))
      (propagated-inputs