summary refs log tree commit diff
path: root/gnu/packages/guile-wm.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:01 +0200
commit9744b3b244f8f95d8b8254d2cbae69e09cdbb714 (patch)
tree5414697ba6ebbb92f268918f29c9d81cd2e2e574 /gnu/packages/guile-wm.scm
parent83a760dd58fe975fc32b94161ae076a726e8b9a0 (diff)
downloadguix-9744b3b244f8f95d8b8254d2cbae69e09cdbb714.tar.gz
gnu: guile-wm: Remove trailing #t from phases.
* gnu/packages/guile-wm.scm (guile-wm)[arguments]: Don't explicitly
return #t.
Diffstat (limited to 'gnu/packages/guile-wm.scm')
-rw-r--r--gnu/packages/guile-wm.scm12
1 files changed, 4 insertions, 8 deletions
diff --git a/gnu/packages/guile-wm.scm b/gnu/packages/guile-wm.scm
index 2487f89f97..ff885506fa 100644
--- a/gnu/packages/guile-wm.scm
+++ b/gnu/packages/guile-wm.scm
@@ -115,8 +115,7 @@ dependencies.")
                    (("^wmdir = .*$")
                     (string-append "wmdir = " out
                                    "/share/guile/site/"
-                                   effective "\n"))))
-               #t))
+                                   effective "\n"))))))
            (add-after 'install 'set-load-path
              (lambda* (#:key inputs outputs #:allow-other-keys)
                ;; Put Guile-XCB's and Guile-WM's modules in the
@@ -136,8 +135,7 @@ dependencies.")
                      (,mods ,(string-append xcb "/share/guile/site/" effective)))
                    `("GUILE_LOAD_COMPILED_PATH" ":" prefix
                      (,gos ,(string-append xcb "/lib/guile/"
-                                           effective "/site-ccache")))))
-               #t))
+                                           effective "/site-ccache")))))))
            (add-after 'install 'install-go-files
              (lambda* (#:key outputs inputs #:allow-other-keys)
                (let* ((out (assoc-ref outputs "out"))
@@ -158,8 +156,7 @@ dependencies.")
                                     (go   (string-append object-dir base ".go")))
                                (invoke "guild" "compile" "-L" module-dir
                                        file "-o" go)))
-                           (find-files module-dir "\\.scm$"))
-                 #t)))
+                           (find-files module-dir "\\.scm$")))))
            (add-after 'install 'install-xsession
              (lambda* (#:key outputs #:allow-other-keys)
                ;; add a .desktop file to xsessions
@@ -175,8 +172,7 @@ dependencies.")
                                     Comment=~a~@
                                     Exec=~a/bin/guile-wm~@
                                     Type=Application~%"
-                             ,name ,synopsis %output))))
-               #t)))))
+                             ,name ,synopsis %output)))))))))
       (native-inputs (list guile-2.2 guile-xcb pkg-config texinfo))
       (inputs (list guile-2.2 guile-xcb))
       (home-page "https://github.com/mwitmer/guile-wm/releases")