summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-25 00:25:15 +0200
commit57df83e07d4b5e78d9a54c1a88d05b4a9ed65714 (patch)
tree76684e63965e9ad6e37d9d45bc3159e6c9782cd0 /gnu/packages/guile-xyz.scm
parent43d9ed7792808638eabb43aa6133f1d6186c520b (diff)
parent136b7d81f0eb713783e9ea7cf7f260a2b6252dfd (diff)
downloadguix-57df83e07d4b5e78d9a54c1a88d05b4a9ed65714.tar.gz
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 03fd63837e..365f909c2c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2195,3 +2195,40 @@ serializing continuations or delimited continuations.")
        "This package allows you to compile a Guile Python file to any target
 from @code{tree-il}.")
       (license license:lgpl2.0+))))
+
+(define-public guile-file-names
+  (package
+    (name "guile-file-names")
+    (version "0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://brandon.invergo.net/software/download/"
+                                  "guile-file-names/guile-file-names-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1kwx5hanl40960w2nhyga7ry4l6c3c57zdrihk4yajj87vn3pmi8"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-target-directory
+           (lambda _
+             (substitute* "src/Makefile.in"
+               (("guilemoddir = \\$\\(GUILE_SITE\\)")
+                "guilemoddir = $(datadir)/guile/site/$(GUILE_EFFECTIVE_VERSION)\n"))
+             #t)))))
+    (inputs
+     `(("guile" ,guile-2.2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://gitlab.com/brandoninvergo/guile-file-names")
+    (synopsis "Manipulate file names")
+    (description
+     "The @code{(file-names)} module provides tools for manipulating file
+names.  The module was built on the idea that doing anything more than a
+non-trivial modification of a file name string is a pain (making sure all
+slashes are present and accounted for, resolving @code{.} and @code{..}, etc).
+Inevitably, you have to break the string up into chunks and operate on that
+list of components.  This module takes care of that for you.")
+    (license license:lgpl3+)))