summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authordivoplade <d@divoplade.fr>2020-10-22 01:14:27 +0200
committerLudovic Courtès <ludo@gnu.org>2020-10-26 22:56:28 +0100
commita8c1eabaf165eb37a1d3a234ccd64603f23396a2 (patch)
treea5f4b42950d2b9110fd4606b023d966c8352290e /gnu/packages/guile-xyz.scm
parentf503cfc9c51ea4ddd6cc9c027f1897e7866e411e (diff)
downloadguix-a8c1eabaf165eb37a1d3a234ccd64603f23396a2.tar.gz
gnu: Add guile-mkdir-p.
* gnu/packages/guile-xyz.scm (guile-mkdir-p): New variable.

Co-authored-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 12ded23990..a204d15611 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4044,3 +4044,42 @@ itself is an implementation of multicast DNS (mDNS) and DNS Service
 Discovery (DNS-SD).")
     (home-page "https://www.nongnu.org/guile-avahi/")
     (license license:lgpl3+)))
+
+(define-public guile-mkdir-p
+  (package
+    (name "guile-mkdir-p")
+    (version "1.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://code.divoplade.fr/mkdir-p.git")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "01k20rjcv6p0spmw8ls776aar6bfw0jxw46d2n12w0cb2p79xjv8"))
+       (file-name (git-file-name name version))
+       (snippet
+        `(begin
+           (with-output-to-file ".tarball-version"
+             (lambda _ (format #t "~a~%" ,version)))
+           #t))))
+    (build-system gnu-build-system)
+    (arguments `())
+    (native-inputs
+     `(("guile" ,guile-3.0)
+       ("texinfo" ,texinfo)
+       ("autoconf" ,autoconf)
+       ("autoconf-archive" ,autoconf-archive)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)
+       ("gettext" ,gnu-gettext)))
+    (inputs `(("guile" ,guile-3.0)))
+    (synopsis "Implementation of a recursive @code{mkdir} for Guile")
+    (description
+     "This package provides within the @code{(mkdir-p)} module the
+@code{mkdir-p} function that tries to create the chain of directories
+recursively.  It also provides new versions of @code{open-output-file},
+@code{call-with-output-file} and @code{with-output-to-file} to create the
+directory of its argument if it does not exist.")
+    (home-page "https://mkdir-p.divoplade.fr")
+    (license license:asl2.0)))