summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-07-17 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:57 +0200
commitae74b3020ca0f5fd2a714cfd14ac949833dcd69d (patch)
tree18e0f926f38df934c7464bb4fd7028875b06cfc8 /gnu/packages/guile-xyz.scm
parent19d576c645a822a22fc82fb8aef35405628a1b98 (diff)
downloadguix-ae74b3020ca0f5fd2a714cfd14ac949833dcd69d.tar.gz
gnu: guile-bash: Modernise.
* gnu/packages/guile-xyz.scm (guile-bash)[inputs]: Use MODIFY-INPUTS.
[arguments]: Use SUBSTITUTE-KEYWORD-ARGUMENTS.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 98f2fac5cf..a85c7e0fc4 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -476,19 +476,20 @@ and then run @command{scm example.scm}.")
     (inherit guile2.0-bash)
     (name "guile-bash")
     (inputs
-     `(("guile" ,guile-3.0-latest)
-       ,@(assoc-remove! (package-inputs guile2.0-bash) "guile")))
+     (modify-inputs (package-inputs guile2.0-bash)
+       (replace "guile" guile-3.0-latest)))
     (arguments
-     `(#:tests? #f
-       #:phases (modify-phases %standard-phases
-                  (add-after 'install 'install-guile
-                    (lambda* (#:key inputs outputs #:allow-other-keys)
-                      (copy-recursively
-                       (string-append (assoc-ref outputs "out")
-                                      (assoc-ref inputs "guile") "/share")
-                       (string-append (assoc-ref outputs "out") "/share"))
-                      #t)))
-       ,@(package-arguments guile2.0-bash)))))
+     (substitute-keyword-arguments (package-arguments guile2.0-bash)
+       ;; XXX The tests succeed with Guile 2.0 but fail with 3.0.
+       ((#:tests? _ #f) #f)
+       ((#:phases phases #~%standard-phases)
+        #~(modify-phases #$phases
+            (add-after 'install 'install-guile
+              (lambda* (#:key inputs outputs #:allow-other-keys)
+                (copy-recursively
+                 (string-append (assoc-ref outputs "out")
+                                (assoc-ref inputs "guile") "/share")
+                 (string-append (assoc-ref outputs "out") "/share"))))))))))
 
 (define-public guile-8sync
   (let ((commit "183b4f02e68279d4984e79b79e06bfcf1861fcbf") (revision "0"))