summary refs log tree commit diff
path: root/gnu/packages/guile-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-08-14 02:00:56 +0200
commitf4012ed2376227a8774d6dd2220cbc852487897a (patch)
tree73ba29f227bd13c6552c47bd75bc5cc057c1df55 /gnu/packages/guile-xyz.scm
parentacb38e3fdb19d58f93c071670ed3a92eca63b3ff (diff)
downloadguix-f4012ed2376227a8774d6dd2220cbc852487897a.tar.gz
gnu: guile2.0-bash: Remove native-input labels.
* gnu/packages/guile-xyz.scm (guile2.0-bash)[native-inputs]:
Remove input labels.
Diffstat (limited to 'gnu/packages/guile-xyz.scm')
-rw-r--r--gnu/packages/guile-xyz.scm17
1 files changed, 7 insertions, 10 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index a032824ca1..780c88ba3a 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -440,16 +440,13 @@ dictionary and suggesting spelling corrections.")
                ;; Install 'lib/bash' as Bash 4.4 expects.
                (string-append "--libdir=" (assoc-ref %outputs "out")
                               "/lib/bash"))))
-      (native-inputs `(("pkg-config" ,pkg-config)
-                       ("autoconf" ,autoconf)
-                       ("automake" ,automake)
-                       ("libtool" ,libtool)
-                       ;; Gettext brings 'AC_LIB_LINKFLAGS_FROM_LIBS'.
-                       ("gettext" ,gettext-minimal)
-
-                       ;; Bash with loadable module support, for the test
-                       ;; suite.
-                       ("bash-full" ,bash)))
+      (native-inputs
+       (list autoconf
+             automake
+             bash                    ; with loadable module support, for tests
+             gettext-minimal         ; for AC_LIB_LINKFLAGS_FROM_LIBS
+             libtool
+             pkg-config))
       (inputs `(("guile" ,guile-2.0)
                 ("bash:include" ,bash "include")))
       (home-page "https://git.sr.ht/~kaction/guile-bash")