summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-29 17:37:00 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-29 17:37:00 +0100
commit4eae7980753649fd8b3cfdb92f755acf0a2108e8 (patch)
treebb66c6831823757ad9f56d98637e154ceaf5a595 /gnu/packages/guile.scm
parent471cdfdb193357de7d76600ce6a5dcdbdbba1320 (diff)
downloadguix-4eae7980753649fd8b3cfdb92f755acf0a2108e8.tar.gz
gnu: guile-next: Update to 2.1.1.
* gnu/packages/guile.scm (guile-next)[source]: Update to 2.1.1.
[arguments, native-inputs]: Move to...
(guile-for-guile-emacs): ... here.  New fields.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm41
1 files changed, 19 insertions, 22 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 6d2341a428..96d5288e4a 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -194,22 +194,33 @@ without requiring the source code to be rewritten.")
 (define-public guile-next
   (package (inherit guile-2.0)
     (name "guile-next")
-    (version "20151025.e5bccb6")
+    (version "2.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://alpha.gnu.org/gnu/guile/guile-"
+                                  version ".tar.xz"))
+              (sha256
+               (base32
+                "0nixmx7as79g8rr8bvznh59pwcc2jd22cfk17v309p57zp2c255r"))))
+    (synopsis "Snapshot of what will become version 2.2 of GNU Guile")))
+
+(define-public guile-for-guile-emacs
+  (package (inherit guile-next)
+    (name "guile-for-guile-emacs")
+    (version "20150510.d8d9a8d")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "git://git.sv.gnu.org/guile.git")
-                    (commit "e5bccb6e5df3485152bc6501e1f36275e09c6352")))
-              (file-name (string-append name "-" version "-checkout"))
+                    (url "git://git.hcoop.net/git/bpt/guile.git")
+                    (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
               (sha256
                (base32
-                "0z7ywryfcargrpz8hdrz6sfs06c2h2y9baqin3mbjvvg96a5bx47"))))
-
+                "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
     (arguments
      (substitute-keyword-arguments `(;; Tests aren't passing for now.
                                      ;; Obviously we should re-enable this!
                                      #:tests? #f
-                                     ,@(package-arguments guile-2.0))
+                                     ,@(package-arguments guile-next))
        ((#:phases phases)
         `(modify-phases ,phases
            (add-after 'unpack 'autogen
@@ -220,7 +231,6 @@ without requiring the source code to be rewritten.")
                          (substitute* "build-aux/git-version-gen"
                            (("#!/bin/sh") (string-append "#!" (which "sh"))))
                          #t))))))
-    (synopsis "Snapshot of what will become version 2.2 of GNU Guile")
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
@@ -228,20 +238,7 @@ without requiring the source code to be rewritten.")
        ("flex" ,flex)
        ("texinfo" ,texinfo)
        ("gettext" ,gnu-gettext)
-       ,@(package-native-inputs guile-2.0)))))
-
-(define-public guile-for-guile-emacs
-  (package (inherit guile-next)
-    (name "guile-for-guile-emacs")
-    (version "20150510.d8d9a8d")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url "git://git.hcoop.net/git/bpt/guile.git")
-                    (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
-              (sha256
-               (base32
-                "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))))
+       ,@(package-native-inputs guile-next)))))
 
 
 ;;;