summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-30 12:48:11 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 20:07:49 +0200
commita49536e32008cd445b36d0412e9f2b67a35d9d3b (patch)
tree14dee5dc44544b95499d564cfe20b81170d44be7 /gnu/packages/guile.scm
parent1c78f71beb39e9c3bc49f2493fa8f36d07892433 (diff)
downloadguix-a49536e32008cd445b36d0412e9f2b67a35d9d3b.tar.gz
gnu: guile-3.0: Update to 3.0.9.
* gnu/packages/guile.scm (guile-3.0): Update to 3.0.9.
[source]: Remove patch.
[arguments]: Only apply 'adjust-bootstrap-flags on powerpc-linux once.
(guile-3.0-latest): Point to guile-3.0.
* gnu/packages/patches/guile-cross-compilation.patch: Remove file
(again).
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm52
1 files changed, 7 insertions, 45 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 3b05aaf5a8..92658a2d69 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -15,7 +15,7 @@
 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
-;;; Copyright © 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020-2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2021 Timothy Sample <samplet@ngyro.com>
 ;;;
@@ -310,15 +310,15 @@ without requiring the source code to be rewritten.")
   (package
     (inherit guile-2.2)
     (name "guile")
-    (version "3.0.8")
+    (version "3.0.9")
     (source (origin
               (inherit (package-source guile-2.2))
               (uri (string-append "mirror://gnu/guile/guile-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "04wagg0zr0sib0w9ly5jm91jplgfigzfgmy8fjdlx07jaq50d9ys"))
-              (patches (search-patches "guile-cross-compilation.patch"))
+                "03bm1mnfc9kkg2ls942a0js7bxrdzmcffgrgg6anwdmjfan2a9hs"))
+              (patches '())
               ;; Replace the snippet because the oom-test still
               ;; fails on some 32-bit architectures.
               (snippet '(begin
@@ -334,7 +334,7 @@ without requiring the source code to be rewritten.")
        (delete "gmp" "libltdl")))
     (arguments
      (substitute-keyword-arguments (package-arguments guile-2.0)
-       ;; Guile 3.0.8 is bit-reproducible when built in parallel, thanks to
+       ;; Guile 3.0.9 is bit-reproducible when built in parallel, thanks to
        ;; its multi-stage build process for cross-module inlining, except when
        ;; cross-compiling.
        ((#:parallel-build? _ #f)
@@ -365,17 +365,8 @@ without requiring the source code to be rewritten.")
                  (("!#")
                   "!#\n(exit 77)\n"))))
 
-           ,@(if (string-prefix? "powerpc-" (%current-system))
-                 `((add-after 'unpack 'adjust-bootstrap-flags
-                     (lambda _
-                       ;; Upstream knows about suggested solution.
-                       ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
-                       (substitute* "bootstrap/Makefile.in"
-                         (("^GUILE_OPTIMIZATIONS.*")
-                          "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
-                 '())
            ,@(if (target-ppc32?)
-               `((replace 'adjust-bootstrap-flags
+               `((add-after 'unpack 'adjust-bootstrap-flags
                    (lambda _
                      ;; Upstream knows about suggested solution.
                      ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
@@ -403,36 +394,7 @@ without requiring the source code to be rewritten.")
             (files '("lib/guile/3.0/site-ccache"
                      "share/guile/site/3.0")))))))
 
-(define-public guile-3.0-latest
-  (package
-    (inherit guile-3.0)
-    (version "3.0.9")
-    (source (origin
-              (inherit (package-source guile-3.0))
-              (uri (string-append "mirror://gnu/guile/guile-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "03bm1mnfc9kkg2ls942a0js7bxrdzmcffgrgg6anwdmjfan2a9hs"))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments guile-3.0)
-       ;; Guile 3.0.9 is bit-reproducible when built in parallel, thanks to
-       ;; its multi-stage build process for cross-module inlining, except when
-       ;; cross-compiling.
-       ((#:parallel-build? _ #f)
-        (not (%current-target-system)))
-       ((#:phases phases)
-        `(modify-phases ,phases
-           ,@(if (target-ppc32?)
-               `((replace 'adjust-bootstrap-flags
-                   (lambda _
-                     ;; Upstream knows about suggested solution.
-                     ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=45214
-                     ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977223#46
-                     (substitute* "stage0/Makefile.in"
-                       (("^GUILE_OPTIMIZATIONS.*")
-                        "GUILE_OPTIMIZATIONS = -O1 -Oresolve-primitives -Ocps\n")))))
-               '())))))))
+(define-public guile-3.0-latest guile-3.0)
 
 (define-public guile-3.0/fixed
   ;; A package of Guile that's rarely changed.  It is the one used in the