summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-01-11 11:02:13 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-01-11 11:18:54 +0100
commita8650a70ab70120a3136366180e32b8812df99c2 (patch)
tree31936c608e4273ebb6992f31d0aa4751e969a789 /gnu/packages/guile.scm
parent31ebecf73dadb51ccc72053f54dee36c93a2d0ab (diff)
downloadguix-a8650a70ab70120a3136366180e32b8812df99c2.tar.gz
gnu: guile: Fix tests on emulated architectures.
The stack overflow test limits the virtual memory size using setrlimit with
RLIMIT_AS argument. This is ignored when using QEMU transparent emulation,
causing the test to crash.

* gnu/packages/patches/guile-2.2-skip-so-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/guile.scm (guile-2.2): Add it.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 442f49cbcb..d023ac7760 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -245,7 +245,8 @@ without requiring the source code to be rewritten.")
                 "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))
               (modules '((guix build utils)))
               (patches (search-patches
-                        "guile-2.2-skip-oom-test.patch"))
+                        "guile-2.2-skip-oom-test.patch"
+                        "guile-2.2-skip-so-test.patch"))
 
               ;; Remove the pre-built object files.  Instead, build everything
               ;; from source, at the expense of significantly longer build