summary refs log tree commit diff
path: root/gnu/packages/guile.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-31 04:48:46 -0500
committerMark H Weaver <mhw@netris.org>2015-01-06 19:47:09 -0500
commitb515822de1001170b05bb78be3887c04acbe3653 (patch)
tree28afd05d468f4e89c37594a0579665522adb1c25 /gnu/packages/guile.scm
parent9097e666d48c9b6c0263dcbe60b5af69ff7689f4 (diff)
downloadguix-b515822de1001170b05bb78be3887c04acbe3653.tar.gz
gnu: guile: Apply fixes for arm.
* gnu/packages/patches/guile-arm-fixes.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
* gnu/packages/guile.scm (guile-2.0): Add patch.
Diffstat (limited to 'gnu/packages/guile.scm')
-rw-r--r--gnu/packages/guile.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 7e3b5f847d..0796834369 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2012, 2013, 2014 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -117,7 +117,8 @@ without requiring the source code to be rewritten.")
                                 ".tar.xz"))
             (sha256
              (base32
-              "1qh3j7308qvsjgwf7h94yqgckpbgz2k3yqdkzsyhqcafvfka9l5f"))))
+              "1qh3j7308qvsjgwf7h94yqgckpbgz2k3yqdkzsyhqcafvfka9l5f"))
+            (patches (list (search-patch "guile-arm-fixes.patch")))))
    (build-system gnu-build-system)
    (native-inputs `(("pkgconfig" ,pkg-config)))
    (inputs `(("libffi" ,libffi)