summary refs log tree commit diff
path: root/gnu/packages/hardware.scm
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2021-06-13 00:14:31 +0200
committerBrice Waegeneire <brice@waegenei.re>2021-07-03 17:57:27 +0200
commit9c1720591caf8fafa8e4336a291b9b47c2ddc7e2 (patch)
treeee87a94f17cd34ee289b19a58a7db9569b0186d9 /gnu/packages/hardware.scm
parentcb51663a41e945cd70f9cf6c7d252c6c5136520d (diff)
downloadguix-9c1720591caf8fafa8e4336a291b9b47c2ddc7e2.tar.gz
gnu: Add ddcui.
* gnu/packages/hardware.scm (ddcui): New variable.
Diffstat (limited to 'gnu/packages/hardware.scm')
-rw-r--r--gnu/packages/hardware.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ee47c1780a..707a47fb4b 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -43,11 +43,13 @@
   #:use-module (gnu packages polkit)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages web)
   #:use-module (gnu packages xdisorg)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages xorg)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -100,6 +102,36 @@ calibrated, and restored when the calibration is applied.")
     (license (list license:bsd-3        ; FindDDCUtil.cmake
                    license:gpl2+))))    ; everything else
 
+(define-public ddcui
+  (package
+    (name "ddcui")
+    (version "0.1.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rockowitz/ddcui")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0myma1zw6dlygv3xbin662d91zcnwss10syf12q2fppkrd8qdgqf"))))
+    (build-system cmake-build-system)
+    (arguments
+     '(#:tests? #f))                    ; No test suite
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("ddcutil" ,ddcutil)
+       ("glib" ,glib)
+       ("qtbase" ,qtbase-5)))
+    (home-page "https://www.ddcutil.com/")
+    (synopsis "Graphical user interface for ddcutil")
+    (description "ddcui is a graphical user interface for ddcutil, implemented
+using Qt.  It provide a dynamic way to inspect and configure external monitors
+through the Display Data Channel Command Interface (@dfn{DDC/CI}) protocol.")
+    (license (list license:gpl2+))))
+
 (define-public edid-decode
   (let ((commit "74b64180d67bb009d8d9ea1b6f18ad41aaa16396") ; 2020-04-22
         (revision "1"))