summary refs log tree commit diff
path: root/gnu/packages/haskell-apps.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-03 06:17:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 01:14:03 +0200
commitb35adf09e7e1d881b7aba041c7672e20ebf7c8c4 (patch)
treea3825b198265deaaae1e3176afe1dee19bf2cc3b /gnu/packages/haskell-apps.scm
parenteb72b3d940286f2c2f360b5525a74b6017648c04 (diff)
downloadguix-b35adf09e7e1d881b7aba041c7672e20ebf7c8c4.tar.gz
gnu: corrode: Better construct version number.
* gnu/packages/haskell-apps.scm (corrode)[source]: Actually use the
let-bound COMMIT instead of duplicating it.
[version]: Call GIT-VERSION on it and a new REVISION.
Diffstat (limited to 'gnu/packages/haskell-apps.scm')
-rw-r--r--gnu/packages/haskell-apps.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index d06a0a330f..9e49bbfd9e 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -145,16 +145,17 @@ installation of Haskell libraries and programs.")
    (license license:bsd-3)))
 
 (define-public corrode
-  (let ((commit "b6699fb2fa552a07c6091276285a44133e5c9789"))
+  (let ((revision "0")
+        (commit "b6699fb2fa552a07c6091276285a44133e5c9789"))
     (package
       (name "corrode")
-      (version (string-append "0.0.1-" (string-take commit 7)))
+      (version (git-version "0.0.0" revision commit))
       (source
        (origin
          (method git-fetch)
          (uri (git-reference
                (url "https://github.com/jameysharp/corrode")
-               (commit "b6699fb2fa552a07c6091276285a44133e5c9789")))
+               (commit commit)))
          (file-name (git-file-name name version))
          (sha256
           (base32 "02v0yyj6sk4gpg2222wzsdqjxn8w66scbnf6b20x0kbmc69qcz4r"))))