summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-08-29 21:29:12 -0400
committerTimothy Sample <samplet@ngyro.com>2019-08-31 09:25:48 -0400
commit1ba35ab7237851c740400ece0f62d455d967a2c0 (patch)
treebf7db08dcbce8c822b1834fb17f1c42dc29fedc9 /gnu/packages/haskell-check.scm
parent62e42dfa236a14dcf30994602f2841ac16f26c08 (diff)
downloadguix-1ba35ab7237851c740400ece0f62d455d967a2c0.tar.gz
gnu: cabal-doctest: Move to haskell-check.scm.
* gnu/packages/haskell.scm (cabal-doctest): Move variable from here...
* gnu/packages/haskell-check.scm: ...to here.

Co-authored-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 589eee74d9..1a32382281 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -837,3 +837,28 @@ of generated values by construction.
 To get started quickly, see the examples:
 @uref{https://github.com/hedgehogqa/haskell-hedgehog/tree/master/hedgehog-example}")
     (license license:bsd-3)))
+
+(define-public cabal-doctest
+  (package
+    (name "cabal-doctest")
+    (version "1.0.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "cabal-doctest/cabal-doctest-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0bgd4jdmzxq5y465r4sf4jv2ix73yvblnr4c9wyazazafddamjny"))))
+    (build-system haskell-build-system)
+    (arguments
+     `(#:cabal-revision
+       ("1" "1bk85avgc93yvcggwbk01fy8nvg6753wgmaanhkry0hz55h7mpld")))
+    (home-page "https://github.com/phadej/cabal-doctest")
+    (synopsis "Setup.hs helper for running doctests")
+    (description
+     "To properly work, the @code{doctest} package needs plenty of
+configuration.  This library provides the common bits for writing custom
+@file{Setup.hs} files.")
+    (license license:bsd-3)))