summary refs log tree commit diff
path: root/gnu/packages/haskell-check.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 10:10:18 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:09 -0500
commitad128630cb91f763f6f4c8003297e6bb3cf696c6 (patch)
treeb9f790a0bf8fa27594e137e4cd9f1d7c753f7811 /gnu/packages/haskell-check.scm
parent0841b6f248f6099bdc9b127bc7b34afed62ca6b4 (diff)
downloadguix-ad128630cb91f763f6f4c8003297e6bb3cf696c6.tar.gz
gnu: ghc-hspec-meta: Update to 2.6.0.
* gnu/packages/haskell-check.scm (ghc-hspec-meta): Update to 2.6.0.
[inputs]: Remove 'ghc-async' and add 'ghc-clock'.
Diffstat (limited to 'gnu/packages/haskell-check.scm')
-rw-r--r--gnu/packages/haskell-check.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 2ae02cda61..e734290c41 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -637,7 +637,7 @@ be used to extend Hspec's functionality.")
 (define-public ghc-hspec-meta
   (package
     (name "ghc-hspec-meta")
-    (version "2.4.6")
+    (version "2.6.0")
     (source
      (origin
        (method url-fetch)
@@ -645,13 +645,13 @@ be used to extend Hspec's functionality.")
                            "hspec-meta-" version ".tar.gz"))
        (sha256
         (base32
-         "0qmvk01n79j6skn79r6zalg2pd0x0nqqn9qn8mhg0pgyzcdnfc9b"))))
+         "1n1a4633wfivylglji8920f67mx7qz8j4q58n8p7dxk6yg4h3mz6"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)
        ("ghc-hunit" ,ghc-hunit)
        ("ghc-ansi-terminal" ,ghc-ansi-terminal)
-       ("ghc-async" ,ghc-async)
+       ("ghc-clock" ,ghc-clock)
        ("ghc-hspec-expectations" ,ghc-hspec-expectations)
        ("ghc-setenv" ,ghc-setenv)
        ("ghc-random" ,ghc-random)