summary refs log tree commit diff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:17:58 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:32 -0500
commit59ea213790f6703b66fee6094b3558b9bb5740fa (patch)
treefbb049537f7e8ba666bbd2d3171f56a6ce2129bd /gnu/packages/haskell-web.scm
parent096781a111253211a911b9721b376903e51b18d8 (diff)
downloadguix-59ea213790f6703b66fee6094b3558b9bb5740fa.tar.gz
gnu: ghc-http2: Update to 1.6.5.
* gnu/packages/haskell-web.scm (ghc-http2): Update to 1.6.5.
[inputs]: Remove 'ghc-bytestring-builder' and 'ghc-hex'; add
'ghc-network-byte-order' and 'ghc-base16-bytestring'.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index c80e72a916..c5d216159b 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -286,7 +286,7 @@ Date in Haskell.")
 (define-public ghc-http2
   (package
     (name "ghc-http2")
-    (version "1.6.3")
+    (version "1.6.5")
     (source
      (origin
        (method url-fetch)
@@ -295,14 +295,14 @@ Date in Haskell.")
                            "http2-" version ".tar.gz"))
        (sha256
         (base32
-         "0hww0rfsv6lqx62qzycbcqy5q6rh9k09qkyjkdm5m1sp1z50wqk1"))))
+         "1vlmy8vnp6ml2n2pr11aa5fzigldsscgzmibrni64ykgfvpd3sqn"))))
     (build-system haskell-build-system)
     (inputs
-     `(("ghc-bytestring-builder" ,ghc-bytestring-builder)
-       ("ghc-case-insensitive" ,ghc-case-insensitive)
+     `(("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-network-byte-order" ,ghc-network-byte-order)
        ("ghc-aeson" ,ghc-aeson)
        ("ghc-aeson-pretty" ,ghc-aeson-pretty)
-       ("ghc-hex" ,ghc-hex)
+       ("ghc-base16-bytestring" ,ghc-base16-bytestring)
        ("ghc-unordered-containers" ,ghc-unordered-containers)
        ("ghc-vector" ,ghc-vector)
        ("ghc-word8" ,ghc-word8)