summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:35 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:50 +0100
commit4580d2d3802881ba1406cda2c62195179c125e0e (patch)
tree2b8eba0e5c3941d2643f24af47657213c2c39199 /gnu/packages/haskell-xyz.scm
parent28ba576ff564c4cd4565a2b1b92607e5d509cd62 (diff)
downloadguix-4580d2d3802881ba1406cda2c62195179c125e0e.tar.gz
gnu: ghc-bytestring-lexing: Update to 0.5.0.7.
* gnu/packages/haskell-xyz.scm (ghc-bytestring-lexing): Update to 0.5.0.7.
[native-inputs]: Add ghc-tasty, ghc-tasty-quickcheck, and ghc-tasty-smallcheck.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 67e5606968..6b1f04b465 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1370,7 +1370,7 @@ Compatibility package for older packages.")
 (define-public ghc-bytestring-lexing
   (package
     (name "ghc-bytestring-lexing")
-    (version "0.5.0.2")
+    (version "0.5.0.7")
     (source
      (origin
        (method url-fetch)
@@ -1379,8 +1379,12 @@ Compatibility package for older packages.")
                            version ".tar.gz"))
        (sha256
         (base32
-         "0wrzniawhgpphc6yx1v972gyqxdbv0pizaz9bafahrshyb9svy81"))))
+         "1p7i2haix4m11an3djaq65cnd293hzwqy4cd2i8jxzcl248pk6iy"))))
     (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+       ("ghc-tasty-smallcheck" ,ghc-tasty-smallcheck)))
     (home-page "http://code.haskell.org/~wren/")
     (synopsis "Parse and produce literals from strict or lazy bytestrings")
     (description