summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 18:20:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-07-16 20:12:06 +0200
commit702a10125724c2af7eadfab3a9edf71c3d32936b (patch)
tree410d7aed53005feddd57c597c4604ddf66f50e8d /gnu/packages/haskell-xyz.scm
parent228d29010679b3090cf359fd3d21d7f5bc33b008 (diff)
downloadguix-702a10125724c2af7eadfab3a9edf71c3d32936b.tar.gz
gnu: Use HTTPS for github.com (and subdomains) home pages.
* gnu/packages/bioconductor.scm (r-qvalue)[home-page]: Use HTTPS and
follow permanent redirection.
* gnu/packages/check.scm (python-codecov, python-nosexcover)
[home-page]: Likewise.
* gnu/packages/cran.scm (r-ffbase, r-ggrepel, r-valr)
[home-page]: Likewise.
* gnu/packages/crates-io.scm (rust-block-0.1, rust-dispatch-0.1)
(rust-objc-0.2, rust-objc-exception-0.1)
(rust-objc-foundation-0.1, rust-objc-id-0.1, rust-objc-test-utils-0.0)
(rust-onig-5.0, rust-onig-sys-69.2, rust-vergen-3.1)
[home-page]: Likewise.
* gnu/packages/finance.scm (ledger-agent, keepkey-agent)
[home-page]: Likewise.
* gnu/packages/haskell-check.scm (ghc-tasty-expected-failure)
[home-page]: Likewise.
* gnu/packages/haskell-web.scm (ghc-bsb-http-chunked, ghc-warp)
(ghc-warp-tls)[home-page]: Likewise.
* gnu/packages/haskell-xyz.scm (ghc-configurator, ghc-hasktags)
(ghc-linear, ghc-newtype-generics, ghc-retry, ghc-xdg-basedir)
(ghc-pretty-show)[home-page]: Likewise.
* gnu/packages/java.scm (java-javax-inject)[home-page]: Likewise.
* gnu/packages/libffi.scm (ruby-ffi)[home-page]: Likewise.
* gnu/packages/linux.scm (procenv)[home-page]: Likewise.
* gnu/packages/python-web.scm (python-aiodns, python-flask-htpasswd)
(python-pycares)[home-page]: Likewise.
* gnu/packages/python-xyz.scm (python-progressbar33, python-whatever)
(python-funcy)[home-page]: Likewise.
* gnu/packages/ruby.scm (ruby-rubyzip, ruby-spinach, ruby-gherkin-ruby)
(ruby-code-statistics, ruby-colorize, ruby-wwtd)[home-page]: Likewise.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 234f75dbfc..a5ceef1f54 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2472,7 +2472,7 @@ interface}.")
      `(("ghc-hunit" ,ghc-hunit)
        ("ghc-test-framework" ,ghc-test-framework)
        ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)))
-    (home-page "http://github.com/bos/configurator")
+    (home-page "https://github.com/bos/configurator")
     (synopsis "Configuration management")
     (description
      "This package provides a configuration management library for programs
@@ -5492,7 +5492,7 @@ template-haskell abstract syntax.")
        ("ghc-utf8-string" ,ghc-utf8-string)
        ("ghc-microlens-platform" ,ghc-microlens-platform)
        ("ghc-hunit" ,ghc-hunit)))
-    (home-page "http://github.com/MarcWeber/hasktags")
+    (home-page "https://github.com/MarcWeber/hasktags")
     (synopsis "Make @code{Ctags} and @code{Etags} files for Haskell programs")
     (description
      "This package provides a means of generating tag files for Emacs and
@@ -6991,7 +6991,7 @@ Kaseorg.")
        ("ghc-test-framework" ,ghc-test-framework)
        ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
        ("ghc-hunit" ,ghc-hunit)))
-    (home-page "http://github.com/ekmett/linear/")
+    (home-page "https://github.com/ekmett/linear/")
     (synopsis "Linear algebra library for Haskell")
     (description
      "This package provides types and combinators for linear algebra on free
@@ -8258,7 +8258,7 @@ IPv4, IPv6 and MAC addresses.")
     (native-inputs
      `(("ghc-hspec" ,ghc-hspec)
        ("hspec-discover" ,hspec-discover)))
-    (home-page "http://github.com/sjakobi/newtype-generics")
+    (home-page "https://github.com/sjakobi/newtype-generics")
     (synopsis "Typeclass and set of functions for working with newtypes")
     (description "The @code{Newtype} typeclass represents the packing and
 unpacking of a newtype, and allows you to operate under that newtype with
@@ -9622,7 +9622,7 @@ ByteStrings in the style of other common *nix hex dump tools.")
     (inputs
      `(("ghc-haskell-lexer" ,ghc-haskell-lexer)
        ("ghc-happy" ,ghc-happy)))
-    (home-page "http://wiki.github.com/yav/pretty-show")
+    (home-page "https://wiki.github.com/yav/pretty-show")
     (synopsis "Tools for working with derived `Show` instances")
     (description
      "This package provides a library and an executable for working with
@@ -10565,7 +10565,7 @@ code where you can safely allocate resources.")
        ("ghc-tasty-hunit" ,ghc-tasty-hunit)
        ("ghc-tasty-hedgehog" ,ghc-tasty-hedgehog)
        ("ghc-hedgehog" ,ghc-hedgehog)))
-    (home-page "http://github.com/Soostone/retry")
+    (home-page "https://github.com/Soostone/retry")
     (synopsis "Retry combinators for monadic actions that may fail")
     (description "This package exposes combinators that can wrap
 arbitrary monadic actions.  They run the action and potentially retry
@@ -14351,7 +14351,7 @@ parts.")
         (base32
          "0azlzaxp2dn4l1nr7shsxah2magk1szf6fx0mv75az00qsjw6qg4"))))
     (build-system haskell-build-system)
-    (home-page "http://github.com/willdonnelly/xdg-basedir")
+    (home-page "https://github.com/willdonnelly/xdg-basedir")
     (synopsis "XDG Base Directory library for Haskell")
     (description "This package provides a library implementing the XDG Base Directory spec.")
     (license license:bsd-3)))