summary refs log tree commit diff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 13:54:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-04 16:29:14 +0200
commitddd06ba35dcf93e51261f8fb4c7716c611b0a9ee (patch)
treeed059fb06e01f9fb9148a78245c74d3d5bac33e4 /gnu/packages/haskell-xyz.scm
parentefbe2667561ffa9829359457709300850692d5d2 (diff)
downloadguix-ddd06ba35dcf93e51261f8fb4c7716c611b0a9ee.tar.gz
gnu: Add ghc-data-clist.
* gnu/packages/haskell-xyz.scm (ghc-data-clist): New public variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index f1d2b3b94d..5a18a82f99 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2906,6 +2906,32 @@ manipulating fields of records.")
 Accessor to access state in transformers State monad.")
     (license license:bsd-3)))
 
+(define-public ghc-data-clist
+  (package
+    (name "ghc-data-clist")
+    (version "0.1.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/data-clist/"
+                           "data-clist-" version ".tar.gz"))
+       (sha256
+        (base32 "1mwfhnmvi3vicyjzl33m6pcipi2v887zazyqxygq258ndd010s9m"))))
+    (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)))
+    (arguments
+     `(#:cabal-revision
+       ("1" "13hg7a3d4ky8b765dl03ryxg28lq8iaqj5ky3j51r0i1i4f2a9hy")))
+    (home-page "https://github.com/sw17ch/data-clist")
+    (synopsis "Simple, functional, bidirectional circular list type")
+    (description
+     "This Haskell library provides a simple purely functional circular list,
+or ring, data type: a circular data structure such that if you continue rotating
+the ring in either direction, you'll eventually return to the element you first
+observed.")
+    (license license:bsd-3)))
+
 (define-public ghc-data-default
   (package
     (name "ghc-data-default")