summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-17 16:14:49 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-17 16:14:49 +0200
commit17aca5c4d273c1f514f8623e555660b99ed90fee (patch)
tree145c440984df37cf2a1c7c94f93aac8d98442d37 /gnu/packages/haskell.scm
parent17b59aa0195f156bb65d0ce0ae62551e91a72c77 (diff)
downloadguix-17aca5c4d273c1f514f8623e555660b99ed90fee.tar.gz
Revert "gnu: Add ghc-array." and "gnu: Add ghc-containers."
This reverts commits e5d92c1ce197ec6da891f69565fe550f502f8e7c
and 7d4e377ff5dfb0b708255e30741f2d26407f1677.

These two packages are part of GHC proper.  See the discussion at
<https://lists.gnu.org/archive/html/help-guix/2018-05/msg00090.html>.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm55
1 files changed, 0 insertions, 55 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 39c0c0a4cd..9b26ff56f2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -13,7 +13,6 @@
 ;;; Copyright © 2017, 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Tonton <tonton@riseup.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9467,58 +9466,4 @@ system dependencies.")
 address string against RFC 5322.")
     (license license:bsd-3)))
 
-(define-public ghc-array
-  (package
-   (name "ghc-array")
-   (version "0.5.2.0")
-   (source
-    (origin
-     (method url-fetch)
-     (uri
-      (string-append "https://hackage.haskell.org/package/array-0.5.2.0/array-"
-                     version ".tar.gz"))
-     (file-name (string-append name "-" version ".tar.gz"))
-     (sha256
-      (base32
-       "12v83s2imxb3p2crnlzrpjh0nk6lpysw9bdk9yahs6f37csa5jaj"))))
-   (build-system haskell-build-system)
-   (synopsis "Haskell @code{Data.Array} module")
-   (description "In addition to providing the @code{Data.Array} module as
-specified in the Haskell 2010 Language Report, this package defines the
-classes @code{IArray} of immutable arrays and @code{MArray} of arrays mutable
-within appropriate monads, as well as some instances of these classes.")
-   (home-page "https://hackage.haskell.org/package/array")
-   (license license:bsd-3)))
-
-(define-public ghc-containers
-  (package
-   (name "ghc-containers")
-   (version "0.5.11.0")
-   (source
-    (origin
-     (method url-fetch)
-     (uri
-      (string-append "https://hackage.haskell.org/package/containers-0.5.11.0/containers-"
-                     version ".tar.gz"))
-     (file-name (string-append name "-" version ".tar.gz"))
-     (sha256
-      (base32
-       "0j29w09kvcn1c0yi4clmrdbgs2gqmpxs2m7q80ib2ix1smm25kaq"))))
-   (build-system haskell-build-system)
-   (inputs `(("ghc-array" ,ghc-array)
-             ("ghc-deepseq" ,ghc-deepseq-generics)
-             ("ghc-hunit" ,ghc-hunit)
-             ("ghc-chasingbottoms" ,ghc-chasingbottoms)
-             ("ghc-test-framework" ,ghc-test-framework)
-             ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
-             ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
-             ("ghc-quickcheck" ,ghc-quickcheck)
-             ("ghc-ghc-prim" ,ghc-primitive)))
-   (synopsis "Haskell containers: Assorted concrete container types")
-   (description "This Haskell module provides efficient general-purpose
-implementations of various immutable container types including sets, maps,
-sequences, trees, and graphs.")
-   (home-page "https://hackage.haskell.org/package/containers")
-   (license license:bsd-3)))
-
 ;;; haskell.scm ends here