summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 22:29:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:35 +0100
commit3295a6daf897d2bb4abccd1e162c12fefd8c9815 (patch)
tree96bdebe9b3d122b0cbe9fc31a26ab0d863bdfd20 /gnu/packages/haskell.scm
parentc7f321cff7d6f189a37b184ffa5bff391919194a (diff)
downloadguix-3295a6daf897d2bb4abccd1e162c12fefd8c9815.tar.gz
gnu: ghc-cereal: Update to 0.5.3.0.
* gnu/packages/haskell.scm (ghc-cereal): Update to 0.5.3.0.
[native-inputs]: Add ghc-quickcheck, ghc-fail, ghc-test-framework, and
ghc-test-framework-quickcheck2.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fb1ed8aea8..1b1c5c0d00 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2574,7 +2574,7 @@ Dual to @code{Traversable}.")
 (define-public ghc-cereal
   (package
     (name "ghc-cereal")
-    (version "0.4.1.1")
+    (version "0.5.3.0")
     (source
      (origin
        (method url-fetch)
@@ -2584,8 +2584,13 @@ Dual to @code{Traversable}.")
              ".tar.gz"))
        (sha256
         (base32
-         "15rhfn9hrjm01ksh9xpz9syxsp9vkvpp6b736iqq38wv2wb7416z"))))
+         "1x4aib7nnaf4x2b9zlndq5n5zsqniw78jifkf55nhnbmvryf05n3"))))
     (build-system haskell-build-system)
+    (native-inputs
+     `(("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-fail" ,ghc-fail)
+       ("ghc-test-framework" ,ghc-test-framework)
+       ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)))
     (home-page "https://hackage.haskell.org/package/cereal")
     (synopsis "Binary serialization library")
     (description "This package provides a binary serialization library,