summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-06-15 01:23:57 +0000
committerLudovic Courtès <ludo@gnu.org>2017-06-16 10:31:37 +0200
commit5465af922b5f5e017fa0cdedc1533c1bf94cab44 (patch)
treeafe3a85ca68f5230b7a248fdba1f1eccf8be8f33 /gnu/packages/haskell.scm
parent49fad81827c4db6d0630e6e675887225cb496693 (diff)
downloadguix-5465af922b5f5e017fa0cdedc1533c1bf94cab44.tar.gz
gnu: Add ghc-warp-tls.
* gnu/packages/haskell.scm (ghc-warp-tls): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index de90159ffe..40e418cfe0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -8578,4 +8578,32 @@ and HPACK.  Currently HTTP/2 16 framing and HPACK 10 is supported.")
 based WAI (Web Application Interface in Haskell).")
     (license license:expat)))
 
+(define-public ghc-warp-tls
+  (package
+    (name "ghc-warp-tls")
+    (version "3.2.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "warp-tls-" version "/"
+                           "warp-tls-" version ".tar.gz"))
+       (sha256
+        (base32
+         "14m2bzk5ivz9gdpxlcj6qnh46f2lycm1ybdjnfkj2876zrqwii7m"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-cryptonite" ,ghc-cryptonite)
+       ("ghc-data-default-class" ,ghc-data-default-class)
+       ("ghc-network" ,ghc-network)
+       ("ghc-streaming-commons" ,ghc-streaming-commons)
+       ("ghc-tls" ,ghc-tls)
+       ("ghc-wai" ,ghc-wai)
+       ("ghc-warp" ,ghc-warp)))
+    (home-page "http://github.com/yesodweb/wai")
+    (synopsis "SSL/TLS support for Warp")
+    (description "This package provides SSL/TLS support for Warp,
+a WAI handler, via the native Haskell TLS implementation.")
+    (license license:expat)))
+
 ;;; haskell.scm ends here