summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 23:54:50 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commit86e9076de8ccaac63e7bbb60bfdf0e0bb3fd805e (patch)
tree448f2298b50720a157d2ef435534b96bec59de83 /gnu/packages/haskell.scm
parent426f92ba8dc716744926464b85b1ecd327f184fb (diff)
downloadguix-86e9076de8ccaac63e7bbb60bfdf0e0bb3fd805e.tar.gz
gnu: ghc-split: Update to 0.2.3.1.
* gnu/packages/haskell.scm (ghc-split): Update to 0.2.3.1.
[source]: Remove snippet.
[inputs]: Move from here...
[native-inputs]: ...to here.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 027f0138af..810fbdaad0 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -3346,7 +3346,7 @@ colored output using the ansi-terminal package.")
 (define-public ghc-split
   (package
     (name "ghc-split")
-    (version "0.2.2")
+    (version "0.2.3.1")
     (outputs '("out" "doc"))
     (source
      (origin
@@ -3357,16 +3357,9 @@ colored output using the ansi-terminal package.")
              ".tar.gz"))
        (sha256
         (base32
-         "0xa3j0gwr6k5vizxybnzk5fgb3pppgspi6mysnp2gwjp2dbrxkzr"))
-       (modules '((guix build utils)))
-       (snippet
-        ;; The Cabal file on Hackage is updated, but the tar.gz does not
-        ;; include it.  See
-        ;; <https://hackage.haskell.org/package/split-0.2.2/revisions/>.
-        '(substitute* "split.cabal"
-           (("base <4.8") "base <4.9")))))
+         "12660m16c6sib3laaxn6w9s453pyx1b49myrmzfij372vq5bc5bn"))))
     (build-system haskell-build-system)
-    (inputs
+    (native-inputs
      `(("ghc-quickcheck" ,ghc-quickcheck)))
     (home-page "https://hackage.haskell.org/package/split")
     (synopsis "Combinator library for splitting lists")