summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-13 00:03:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:37 +0100
commitbffa4663c17f412d9d778445ad47cd0c85859bdf (patch)
treec498de7efc780875dc8897a259fdd224cceda293 /gnu/packages/haskell.scm
parent307a0dcea388712ccd116899e8eb30d13ace54bc (diff)
downloadguix-bffa4663c17f412d9d778445ad47cd0c85859bdf.tar.gz
gnu: ghc-binary: Update to 0.8.5.1.
* gnu/packages/haskell.scm (ghc-binary): Update to 0.8.5.1.
[arguments]: Allow building with newer QuickCheck.
[inputs]: Move all from here...
[native-inputs]: ...to here.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b4ac74cab6..dd9228da18 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5936,7 +5936,7 @@ data quickly and efficiently, using the ByteString type.")
 (define-public ghc-binary
   (package
     (name "ghc-binary")
-    (version "0.8.4.1")
+    (version "0.8.5.1")
     (source
      (origin
        (method url-fetch)
@@ -5945,9 +5945,11 @@ data quickly and efficiently, using the ByteString type.")
              version ".tar.gz"))
        (sha256
         (base32
-         "1fp7wxnf57cjzhbb7rgqs6fgws4690zh0dxgl924dj4nzq0cf4wd"))))
+         "15h5zqfw7xmcimvlq6bs8f20vxlfvz7g411fns5z7212crlimffy"))))
     (build-system haskell-build-system)
-    (inputs
+    (arguments
+     `(#:configure-flags (list "--allow-newer=QuickCheck")))
+    (native-inputs
      `(("ghc-random" ,ghc-random)
        ("ghc-test-framework" ,ghc-test-framework)
        ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)