summary refs log tree commit diff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorrsiddharth <s@ricketyspace.net>2017-10-18 03:07:44 +0000
committerLudovic Courtès <ludo@gnu.org>2017-10-22 15:32:17 -0700
commitf78ed5d56f91b74c71ebb329e6162a40744f1580 (patch)
treecfe6362cc99caf37cd3d2b4167899a61a10c8582 /gnu/packages/haskell.scm
parent83c79ea0f8d64c5df68495ca31f4217b12dce312 (diff)
downloadguix-f78ed5d56f91b74c71ebb329e6162a40744f1580.tar.gz
gnu: Add ghc-pretty-hex.
* gnu/packages/haskell.scm (ghc-pretty-hex): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 675632b581..6e69eb65c8 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9648,4 +9648,24 @@ cipher operations using the crypto-api interface.  Known answer tests (KATs)
 for common cryptographic algorithms are included.")
     (license license:bsd-3)))
 
+(define-public ghc-pretty-hex
+  (package
+    (name "ghc-pretty-hex")
+    (version "1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "pretty-hex-" version "/"
+                           "pretty-hex-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ylwkvvjvmpprha9nx83xb8gkhyanhk5fffc0r7lb96n4ch5z6pz"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/GaloisInc/hexdump")
+    (synopsis "Haskell library for hex dumps of ByteStrings")
+    (description "This Haskell library generates pretty hex dumps of
+ByteStrings in the style of other common *nix hex dump tools.")
+    (license license:bsd-3)))
+
 ;;; haskell.scm ends here