summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2020-03-04 11:49:46 -0500
committerJan Nieuwenhuizen <janneke@gnu.org>2020-03-24 23:31:33 +0100
commit9b943db357ad63b7a3d063c658b1f557697ef0fa (patch)
treeec846dd126824f559ba78c9b6b7ed0f31958de25 /gnu/packages/hurd.scm
parent654de94e74547f61a0996cae70ddba2826bfd8d4 (diff)
downloadguix-9b943db357ad63b7a3d063c658b1f557697ef0fa.tar.gz
gnu: hurd: Fix hurd-target?, add hurd-system?.
* gnu/packages/hurd.scm (hurd-target?): Bugfix; the arguments to
string-suffix? to test (%current-system) were transposed, always resulting
in #f.  Use hurd-triplet?.
(hurd-system?): New exported variable.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index c147bac8a3..59d5c31e33 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -34,8 +35,9 @@
   #:use-module (gnu packages base)
   #:use-module (gnu packages texinfo)
   #:use-module (guix git-download)
-  #:export (hurd-triplet?
-            hurd-target?))
+  #:export (hurd-system?
+            hurd-target?
+            hurd-triplet?))
 
 (define (hurd-triplet? triplet)
   (and (string-suffix? "-gnu" triplet)
@@ -45,7 +47,12 @@
   "Return true if the cross-compilation target or the current system is
 GNU/Hurd."
   (or (and=> (%current-target-system) hurd-triplet?)
-      (string-suffix? (%current-system) "-gnu")))
+      (and (not (%current-target-system))
+           (and=> (%current-system) hurd-triplet?))))
+
+(define (hurd-system?)
+  "Return true if the current system is the Hurd."
+  (and=> (%current-system) hurd-triplet?))
 
 (define (hurd-source-url version)
   (string-append "mirror://gnu/hurd/hurd-"