summary refs log tree commit diff
path: root/gnu/packages/idris.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-20 10:49:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:52 +0200
commitb97f549b14402421fcfb360ddd4cff7de93b9af0 (patch)
tree855c25f617f75e29e77ff2b52b754e1249164d30 /gnu/packages/idris.scm
parentb74ca403cbb11c60d57b6a0148d97c6572019754 (diff)
downloadguix-b97f549b14402421fcfb360ddd4cff7de93b9af0.tar.gz
gnu: Update Haskell ecosystem.
Bump packages’ versions to the lastest Stackage or Hackage
release. Since packages are interdependent, do so in a single commit.

525 packages have been updated.

These packages have been removed, because they fail to build, have no
newer version available and no dependencies:

corrode
ghc-easytest
ghc-edisonapi
ghc-edisoncore
ghc-pandoc-types
ghc-regex-tdfa-text

These have been removed, because they are no longer required:

ghc-happy-1.19.9
ghc-prettyprinter-1.6
ghc-protolude-0.3

ghc-pandoc-citeproc and pandoc-citeproc have been removed, because pandoc
does not use them any more.

Co-authored-by: Xinglu Chen <public@yoctocell.xyz>
Diffstat (limited to 'gnu/packages/idris.scm')
-rw-r--r--gnu/packages/idris.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/idris.scm b/gnu/packages/idris.scm
index ca2772b904..0e8502b908 100644
--- a/gnu/packages/idris.scm
+++ b/gnu/packages/idris.scm
@@ -97,12 +97,11 @@
            (lambda _
              (setenv "LD_LIBRARY_PATH" (string-append (getcwd) "/dist/build"))
              #t))
-         (add-after 'unpack 'update-constraints
+         (add-before 'configure 'update-constraints
            (lambda _
              (substitute* "idris.cabal"
-               (("ansi-terminal < 0\\.9") "ansi-terminal < 0.10")
-               (("cheapskate >= 0\\.1\\.1\\.2 && < 0\\.2") "cheapskate >= 0.1.1.1 && < 0.2"))
-             #t))
+               (("(aeson|ansi-terminal|haskeline|megaparsec|optparse-applicative)\\s+[^,]+" all dep)
+                dep))))
          (add-before 'configure 'set-cc-command
            (lambda _
              (setenv "CC" "gcc")