summary refs log tree commit diff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-19 13:41:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:29 +0200
commit7ca1a0203080840ddb2070f63a85ce2c76136709 (patch)
treeba1f161ca4b485d83c4dcbfd5af7e6763fa169b9 /gnu/packages/image-processing.scm
parent81eb92105f210516d82f838bdc3d8e8d9d4253bb (diff)
downloadguix-7ca1a0203080840ddb2070f63a85ce2c76136709.tar.gz
gnu: Add python-spatial-image.
* gnu/packages/image-processing.scm (python-spatial-image): New variable.

Change-Id: I0e2bbfb94499aca71b33703153ad408530b60658
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 6c199792f8..00b6311c23 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -50,6 +50,7 @@
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
+  #:use-module (guix build-system pyproject)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
   #:use-module (gnu packages base)
@@ -90,6 +91,7 @@
   #:use-module (gnu packages pretty-print)
   #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-build)
   #:use-module (gnu packages python-check)
   #:use-module (gnu packages python-science)
   #:use-module (gnu packages python-xyz)
@@ -1702,6 +1704,43 @@ purposes.")
 segmentation.")
     (license license:expat)))
 
+(define-public python-spatial-image
+  (package
+    (name "python-spatial-image")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "spatial_image" version))
+       (sha256
+        (base32 "0blyjwgv6bqpg7r3f4dcs7x27ysfm8n9y0zk5j7dxj74lma3wdsm"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-numpy python-pytest python-pytest-mypy
+                             python-xarray python-xarray-dataclasses))
+    (native-inputs (list python-flit-core python-pytest))
+    (home-page "https://github.com/spatial-image/spatial-image")
+    (synopsis "Multi-dimensional spatial image data structure")
+    (description "This package implements a multi-dimensional spatial image
+data structure for scientific Python.
+
+To facilitate:
+
+@itemize
+@item Multi-scale processing and analysis
+@item Registration
+@item Resampling
+@item Subregion parallel processing
+@item Coupling with meshes, point sets, and annotations
+@end itemize
+
+with scientific images, which are typically multi-dimensional with anisotropic
+sampling, this package provides a spatial-image data structure.  In addition
+to an N-dimensional array of pixel values, spatial metadata defines the
+location of the pixel sampling grid in space time.  It also labels the array
+dimensions.  This metadata is easily utilized and carried through image
+processing pipelines.")
+    (license license:expat)))
+
 (define-public labelme
   (package
     (name "labelme")