summary refs log tree commit diff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2021-06-01 10:12:08 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2021-06-01 10:19:48 +0100
commitd769fcd683edd8f93fa549dd0d60ec7d073e0839 (patch)
tree6d71e23af42c95dd0864e69f47eae7a965fe6a53 /gnu/packages/image-processing.scm
parentfd0650eebe33d2ffcded9cd4a66f5e80232d8cd6 (diff)
downloadguix-d769fcd683edd8f93fa549dd0d60ec7d073e0839.tar.gz
gnu: vtk: Wrap python modules.
* gnu/packages/image-processing.scm (vtk)[inputs]: Add python.
[arguments]: Add VTK_WRAP_PYTHON and VTK_PYTHON_VERSION flags.
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index ed21b26812..da2653c546 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -16,6 +16,7 @@
 ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Andy Tai <atai@atai.org>
 ;;; Copyright © 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
+;;; Copyright © 2021 Paul Garlick <pgarlick@tourbillion-technology.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -298,6 +299,8 @@ many popular formats.")
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_theora=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_tiff=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_zlib=ON"
+                           "-DVTK_WRAP_PYTHON=ON"
+                           "-DVTK_PYTHON_VERSION:STRING=3"
                            )
        #:phases
          (modify-phases %standard-phases
@@ -328,6 +331,7 @@ many popular formats.")
        ("netcdf" ,netcdf)
        ("png" ,libpng)
        ("proj" ,proj.4)
+       ("python", python)
        ;("pugixml" ,pugixml)
        ("sqlite" ,sqlite)
        ("tiff" ,libtiff)
@@ -871,6 +875,7 @@ libraries designed for computer vision research and implementation.")
          ;; variable in the installed CMake files.  This is necessary as other
          ;; packages using insight-toolkit could not be configured otherwise.
          "-DGTEST_ROOT=gtest")
+
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'do-not-tune