summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorHilton Chain <hako@ultrarare.space>2023-07-17 15:29:03 +0800
committerLudovic Courtès <ludo@gnu.org>2023-08-16 22:51:51 +0200
commit63cf5a2a4eb64c31f5811b77e182965fd3320af0 (patch)
tree9c3cb5aea4bf1b2b44d4a1ab5ce570ffb3901c1f /gnu/packages/image.scm
parent72ce8696904640981aa065d63576c5d6e855b2fc (diff)
downloadguix-63cf5a2a4eb64c31f5811b77e182965fd3320af0.tar.gz
gnu: libwebp: Replace with 1.3.1. [fixes CVE-2023-1999]
* gnu/packages/image.scm (libwebp/fixed): New variable.
(libwebp)[replacement]: Assign it to new field.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d0867d738b..75f9e3c691 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1432,6 +1432,7 @@ language bindings to VIGRA.")
   (package
     (name "libwebp")
     (version "1.2.4")
+    (replacement libwebp/fixed)
     (source
      (origin
        ;; No tarballs are provided for >0.6.1.
@@ -1470,6 +1471,22 @@ to PNG when lossy compression is acceptable for the red/green/blue color
 channels.")
     (license license:bsd-3)))
 
+(define libwebp/fixed
+  (package
+    (inherit libwebp)
+    (name "libwebp")
+    (version "1.3.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://chromium.googlesource.com/webm/libwebp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1aas6gwy7kfcq34cil781kcsl286khh9grwcx7k4d2n1g7zcpl3m"))))))
+
 (define-public libmng
   (package
     (name "libmng")