summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-09-24 02:00:00 +0200
commitdf7c91785c3b01e1634d3bb01ef137574fa11d87 (patch)
tree2eb00692de906c31610c3baa8c9545cbe67efdb4 /gnu/packages/image.scm
parent63efa203d39f497f58eed0678e15a1487e3ac9c4 (diff)
downloadguix-df7c91785c3b01e1634d3bb01ef137574fa11d87.tar.gz
gnu: imgp: Update to 2.9.
* gnu/packages/image.scm (imgp): Update to 2.9.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index a632a02139..bd3bcf964d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1765,23 +1765,22 @@ PNG, and performs PNG integrity checks and corrections.")
 (define-public imgp
   (package
     (name "imgp")
-    (version "2.8")
+    (version "2.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "imgp" version))
        (sha256
-        (base32 "0q99h9wv9rynig0s0flnr9mxi541zzl0gw8vh4y6m5x132diilri"))))
+        (base32 "0avdgr4fx643jg9wzwm65y14s56bnrn3hmkw7v0mcyvxn88vxwiq"))))
     (build-system python-build-system)
     (arguments
-     `(#:tests? #f ;there are no tests
+     `(#:tests? #f                      ;there are no tests
        #:phases
        (modify-phases %standard-phases
          ;; setup.py expects the file to be named 'imgp'.
          (add-after 'unpack 'rename-imgp
            (lambda _
-             (rename-file "imgp.py" "imgp")
-             #t)))))
+             (rename-file "imgp.py" "imgp"))))))
     (inputs
      (list python-pillow))
     (home-page "https://github.com/jarun/imgp")