summary refs log tree commit diff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-10 11:35:50 +0200
commit3a4de6b2d2fdb515c8186cbceab4259aab91cadf (patch)
tree7eaa4544ba397ce3493c26679ee2eafe76f8e448 /gnu/packages/imagemagick.scm
parentcaaf1933a453e7f3f8d7444f2c97dac3f8a93e1c (diff)
downloadguix-3a4de6b2d2fdb515c8186cbceab4259aab91cadf.tar.gz
gnu: Add missing quotes in phase names passed to 'modify-phases'.
This is a followup to f8503e2.

* gnu/packages/gnome.scm (glib-networking): Add missing quotes before
  phase names passed to 'modify-phases'.
  (libsoup): Likewise.
  (gnome-terminal): Likewise.
  (colord): Likewise.
  (geoclue): Likewise.
* gnu/packages/gtk.scm (at-spi2-core, at-spi2-atk): Likewise.
* gnu/packages/haskell.scm (ghc-network): Likewise.
* gnu/packages/imagemagick.scm (perl-image-magick): Likewise.
* gnu/packages/video.scm (aalib): Likewise.
* gnu/packages/web.scm (nginx): Likewise.
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index 2a68627dc6..ab663b5a41 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -112,7 +112,7 @@ text, lines, polygons, ellipses and Bézier curves.")
      `(#:phases
        (modify-phases %standard-phases
          (add-before
-          configure image-magick-flags
+          'configure 'image-magick-flags
           (lambda* (#:key inputs #:allow-other-keys)
             (let ((im (assoc-ref inputs "imagemagick")))
               (substitute* "Makefile.PL"
@@ -121,7 +121,7 @@ text, lines, polygons, ellipses and Bézier curves.")
                 (("my \\$LIBS_magick = .*")
                  "my $LIBS_magick = `pkg-config --libs ImageMagick`;\n")))))
          (add-before
-          check skip-mpeg-tests
+          'check 'skip-mpeg-tests
           (lambda _
             ;; TODO: MPEG tests fail even though our imagemagick supports
             ;; MPEG.  Has been reported elsewhere,