summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-12 03:35:27 +0000
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-12 06:04:39 +0000
commita83bab6bae25cf4b745bc21507da328cdbb3c505 (patch)
treea96db9cee43517d11d9f1a7200691c5a8a71a7fb /gnu/packages/irc.scm
parent9e3b4d69dae190a7c2bd670e5f42ca6a522c5708 (diff)
downloadguix-a83bab6bae25cf4b745bc21507da328cdbb3c505.tar.gz
gnu: inspircd: Update to 3.12.0.
* gnu/packages/irc.scm (inspircd): Update to 3.12.0.
[arguments]: Don't explicitly return #t from phases.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 771616025c..5b045fa520 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -614,7 +614,7 @@ but can also be used independently as a logging bot.")
 (define-public inspircd
   (package
     (name "inspircd")
-    (version "3.8.1")
+    (version "3.12.0")
     (source
      (origin
        (method git-fetch)
@@ -623,7 +623,7 @@ but can also be used independently as a logging bot.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1i30649dw84iscxa5as81g96f393mn1i883aq4za5ypdinr5x65g"))))
+        (base32 "0xlfs269iaw7dfryzl6vjzqsn2g4nqh6kpf5xfgk3zbjhqaczknx"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags (map (lambda (module)
@@ -649,8 +649,7 @@ but can also be used independently as a logging bot.")
          (add-before 'configure 'module-configure
            (lambda* (#:key configure-flags #:allow-other-keys)
              (apply invoke "./configure"
-                    configure-flags)
-             #t))
+                    configure-flags)))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -662,8 +661,7 @@ but can also be used independently as a logging bot.")
                        (string-append "--prefix=" out-lib name)
                        (string-append "--binary-dir=" out-bin)
                        (string-append "--module-dir=" out-lib name "/modules/")
-                       (string-append "--config-dir=" out-etc name)))
-             #t)))))
+                       (string-append "--config-dir=" out-etc name))))))))
     (native-inputs
      (list pkg-config))
     (inputs