summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-28 11:57:26 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-03-01 11:09:32 +0200
commite288f0075cde7c645e1f914737f5f2b3d439bcd2 (patch)
tree13f06b7f9c52b51ab68b0df20d6ee8cfa4e7b9e8 /gnu/packages/irc.scm
parenta61bd6a5e3f375c08794519f4c9528c899eb5f32 (diff)
downloadguix-e288f0075cde7c645e1f914737f5f2b3d439bcd2.tar.gz
gnu: weechat: Move to irc.scm.
* gnu/packages/weechat.scm (weechat): Move from here ...
* gnu/packages/irc.scm (weechat): ... to here.
* gnu/packages/weechat.scm: Delete file.
* gnu-system.am (GNU_SYSTEM_MODULES): Remove weechat.scm.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm77
1 files changed, 77 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 07b72bdb94..9f5b766c5c 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -23,14 +25,28 @@
   #:use-module (guix packages)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages aspell)
+  #:use-module (gnu packages autogen)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
+  #:use-module (gnu packages cyrus-sasl)
+  #:use-module (gnu packages file)
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages guile)
+  #:use-module (gnu packages lua)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages kde)
   #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
   #:use-module (gnu packages qt)
+  #:use-module (gnu packages tcl)
   #:use-module (gnu packages tls))
 
 (define-public quassel
@@ -111,3 +127,64 @@ irssi, but graphical.")
      "Irssi is a terminal based IRC client for UNIX systems.  It also supports
 SILC and ICB protocols via plugins.")
     (license license:gpl2+)))
+
+(define-public weechat
+  (package
+    (name "weechat")
+    (version "1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://weechat.org/files/src/weechat-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "19apd3hav77v74j7flicai0843k7wrkr2fd3q2ayvzkgnbrrp1ai"))
+              (patches (list (search-patch "weechat-python.patch")))))
+    (build-system gnu-build-system)
+    (native-inputs `(("autoconf" ,autoconf)
+                     ("pkg-config" ,pkg-config)
+                     ("file" ,file)
+                     ("autogen" ,autogen)
+                     ("automake" ,automake)
+                     ("libtool" ,libtool)))
+    (inputs `(("ncurses" ,ncurses)
+              ("diffutils" ,diffutils)
+              ("gettext" ,gnu-gettext)
+              ("libltdl" ,libltdl)
+              ("libgcrypt" ,libgcrypt "out")
+              ("zlib" ,zlib)
+              ("aspell" ,aspell)
+              ("curl" ,curl)
+              ("gnutls" ,gnutls)
+              ("guile" ,guile-2.0)
+              ("openssl" ,openssl)
+              ("cyrus-sasl" ,cyrus-sasl)
+              ("lua" ,lua-5.1)
+              ("python" ,python-2)
+              ("perl" ,perl)
+              ("tcl" ,tcl)))
+    (arguments
+     `(#:configure-flags (list (string-append
+                                "--with-tclconfig="
+                                (assoc-ref %build-inputs "tcl") "/lib"))
+       #:phases (modify-phases %standard-phases
+                  (add-before 'configure 'autogen
+                    (lambda _
+                      (zero? (system* "./autogen.sh"))))
+                  (add-before 'build 'set-python-file-name
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (substitute* "src/plugins/python/weechat-python.c"
+                        (("python2_bin = weechat_python_get_python2_bin.*;")
+                         (string-append "python2_bin = strdup (\""
+                                        (assoc-ref inputs "python")
+                                        "/bin/python\");\n")))
+                      #t)))))
+    (synopsis "Extensible chat client")
+    (description "WeeChat (Wee Enhanced Environment for Chat) is an
+Internet Relay Chat client, which is designed to be light and fast.
+The client uses a curses frontend, and there are remote interfaces
+for Web, Qt, Android and Emacs.  In WeeChat everything can be done
+with a keyboard, though it also supports mouse.  It is customizable
+and extensible with plugins and scripts.")
+    (home-page "http://www.weechat.org/")
+    (license license:gpl3)))