summary refs log tree commit diff
path: root/gnu/packages/iso-codes.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-29 02:00:00 +0200
commit48e66b01d6c0e330dc96a6a480d97006c064187b (patch)
tree4fb855bffb3e68a4fd1e98622aa463388a704599 /gnu/packages/iso-codes.scm
parent59fa040362a08f0e81792cba29f0418d07832532 (diff)
downloadguix-48e66b01d6c0e330dc96a6a480d97006c064187b.tar.gz
gnu: Add iso-codes variant for use within Guix.
* gnu/packages/iso-codes.scm (iso-codes):
Replace with hidden-package that inherits…
(iso-codes/official): …this ‘new’ variable with its previous value.
* gnu/packages/gtk.scm (gtk+)[inputs]:
Use iso-codes/official to prevent mass rebuilds.
Diffstat (limited to 'gnu/packages/iso-codes.scm')
-rw-r--r--gnu/packages/iso-codes.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/iso-codes.scm b/gnu/packages/iso-codes.scm
index c34911fe9b..f8775c5eaa 100644
--- a/gnu/packages/iso-codes.scm
+++ b/gnu/packages/iso-codes.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,7 +29,9 @@
   #:use-module (gnu packages perl)
   #:use-module (gnu packages python))
 
-(define-public iso-codes
+(define-public iso-codes/official
+  ;; This package variant is intended for ‘external’ use, such as users running
+  ;; ‘guix install’, where any deviation from ISO gospel might be harmful.
   (package
     (name "iso-codes")
     (version "4.5.0")
@@ -77,6 +79,25 @@ changes in the ISO standard and will not work with outdated
 information.")
     (license license:gpl2+)))           ; some bits use the lgpl2
 
+(define-public iso-codes
+  ;; This package should be used universally within Guix, e.g., as an input to
+  ;; other Guix packages or in the Guix System installer's country selector.
+  (hidden-package
+   (package
+     (inherit iso-codes/official)
+     (source
+      (origin
+        (inherit (package-source iso-codes/official))
+        (modules '((guix build utils)))
+        (snippet
+         '(begin
+            (substitute* (find-files "." "\\.po$")
+              (("#.*Name for TWN,.*") "")
+              (("^msgid \"Taiwan, .*") "# Guix doesn't use "))
+            (substitute* "data/iso_3166-1.json"
+              (("(Taiwan), [^\"]*" _ name) name))))))
+     (synopsis "Various ISO standards as used by GNU@tie{}Guix"))))
+
 (define-public python-iso639
   (package
     (name "python-iso639")