summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-31 16:45:14 -0400
committerLeo Famulari <leo@famulari.name>2016-08-31 19:04:46 -0400
commit7335ca1d71fb97362170a5ef4bff920e0ce7280a (patch)
tree2bc61eb3c40508a7143a30fc74622d0695ade9ca /gnu/packages/java.scm
parent68c35ba96e41c136da5eabb3b3fa44acbdadc93a (diff)
downloadguix-7335ca1d71fb97362170a5ef4bff920e0ce7280a.tar.gz
gnu: icedtea-6: Update to 1.13.12 [security fixes].
Fixes CVE-2016-{3458,3485,3500,3508,3550,3606}.

* gnu/packages/java.scm (icedtea-6): Update to 1.13.12.
[source]: Remove 'icedtea-remove-overrides' patch.
[arguments]: Move ALSA header substitution to 'patch-paths' phase.
* gnu/packages/patches/icedtea-remove-overrides.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 3e0b034950..7387235c5b 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -337,16 +337,15 @@ build process and its dependencies, whereas Make uses Makefile format.")
 (define-public icedtea-6
   (package
     (name "icedtea")
-    (version "1.13.11")
+    (version "1.13.12")
     (source (origin
               (method url-fetch)
               (uri (string-append
                     "http://icedtea.wildebeest.org/download/source/icedtea6-"
                     version ".tar.xz"))
-              (patches (search-patches "icedtea-remove-overrides.patch"))
               (sha256
                (base32
-                "1grki39a4rf8n74zc0iglcggxxbpniyfh1gk1lb10p63zvvcsvjj"))
+                "1q5iqm3dzqj8w3dwj6qqhczkkrslrfhmn3110klfwq9kyi2nimj8"))
               (modules '((guix build utils)))
               (snippet
                '(substitute* "Makefile.in"
@@ -441,13 +440,7 @@ build process and its dependencies, whereas Make uses Makefile format.")
              (substitute* '("patches/jtreg-jrunscript.patch"
                             "patches/hotspot/hs23/drop_unlicensed_test.patch")
                (("#!/bin/sh") (string-append "#!" (which "sh"))))
-
-             ;; fix path to alsa header in patch
-             (substitute* "patches/openjdk/6799141-split_out_versions.patch"
-               (("ALSA_INCLUDE=/usr/include/alsa/version.h")
-                (string-append "ALSA_INCLUDE="
-                               (assoc-ref %build-inputs "alsa-lib")
-                               "/include/alsa/version.h")))))
+             #t))
          (add-after 'unpack 'patch-paths
            (lambda _
              ;; buildtree.make generates shell scripts, so we need to replace
@@ -475,6 +468,13 @@ build process and its dependencies, whereas Make uses Makefile format.")
                  (("DEF_OBJCOPY *=.*objcopy")
                   (string-append "DEF_OBJCOPY = " (which "objcopy"))))
 
+               ;; fix path to alsa header
+               (substitute* "openjdk.src/jdk/make/common/shared/Sanity.gmk"
+                 (("ALSA_INCLUDE=/usr/include/alsa/version.h")
+                  (string-append "ALSA_INCLUDE="
+                                 (assoc-ref %build-inputs "alsa-lib")
+                                 "/include/alsa/version.h")))
+
                ;; fix hard-coded utility paths
                (substitute* '("openjdk.src/jdk/make/common/shared/Defs-utils.gmk"
                               "openjdk.src/corba/make/common/shared/Defs-utils.gmk")
@@ -764,10 +764,10 @@ build process and its dependencies, whereas Make uses Makefile format.")
        ("openjdk6-src"
         ,(origin
            (method url-fetch)
-           (uri "https://java.net/downloads/openjdk6/openjdk-6-src-b39-03_may_2016.tar.gz")
+           (uri "https://java.net/downloads/openjdk6/openjdk-6-src-b40-22_aug_2016.tar.gz")
            (sha256
             (base32
-             "1brxbsgwcj4js26y5lk6capc3pvghgjidvv9cavw6z8n7c7aw8af"))))
+             "01v4q7g9pa6w7m6yxply5yrin08jgv12fck665xnmp09bpxy8sa5"))))
        ("lcms" ,lcms)
        ("zlib" ,zlib)
        ("gtk" ,gtk+-2)