summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/java.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm21
1 files changed, 13 insertions, 8 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 9a6ca926be..e53bb6b4b9 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -14153,16 +14153,21 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
                license:asl2.0))))
 
 (define-public tla2tools
-  (let* ((version "1.8.0")
-         (tag (string-append "v" version)))
+  ;; This package was originally based on the "v1.8.0" tag, but that merely
+  ;; points to the moving master branch.  That might be because the ‘latest
+  ;; release’ at GitHub is currently 1.7.1.  We'll see!  For now, rather than
+  ;; downgrade to 1.7.1 proper, use the commit that we originally dubbed 1.8.0.
+  (let* ((release "1.7.1")
+         (revision "0")
+         (commit "6932e19083fc6df42473464857fc1280cb5aaecc"))
     (package
       (name "tla2tools")
-      (version version)
+      (version (git-version release revision commit))
       (source (origin
                 (method git-fetch)
                 (uri (git-reference
                       (url "https://github.com/tlaplus/tlaplus")
-                      (commit tag)))
+                      (commit commit)))
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
@@ -14186,7 +14191,7 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
            #:make-flags '("-f" ,build-xml)
            #:phases
            (modify-phases %standard-phases
-            ;; Replace packed libs with references to jars in store
+             ;; Replace packed libs with references to jars in store
              (add-after 'unpack 'replace-libs
                (lambda* (#:key inputs #:allow-other-keys)
                  (define (input-jar input)
@@ -14209,12 +14214,12 @@ can be interpreted by IDEs and static analysis tools to improve code analysis.")
                     ("junit-4.12.jar" . "java-junit")
                     ("easymock-3.3.1.jar" . "java-easymock")))
                  ;; Retain a tiny subset of the original X-Git-*
-                 ;; manifest values just to aid in debugging
+                 ;; manifest values just to aid in debugging.
                  (substitute* ,build-xml
-                   (("\\$\\{git.tag\\}") ,tag))))
+                   (("\\$\\{git.tag\\}") (string-append "v" ,release)))))
              (add-before 'check 'prepare-tests
                (lambda _
-                 ;; pcal tests write to cfg files
+                 ;; The pcal tests write to .cfg files.
                  (for-each (cut chmod <> #o644)
                            (find-files (string-append ,tlatools
                                                       "/test-model/pcal")