summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-04-22 16:09:17 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-05-02 17:35:51 +0200
commitd0184f44d3c1cc2f143e48d769c11f77666bcd68 (patch)
treec76d37f7eca8e59a75e089a8896196783082d6c8 /gnu/packages/java.scm
parent87c31a21a5d8cb75f907fdffaac6dad2c7c6fdad (diff)
downloadguix-d0184f44d3c1cc2f143e48d769c11f77666bcd68.tar.gz
gnu: Add java-junit.
* gnu/packages/java.scm (java-junit): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index e8dcd7e670..fbee1a3fb3 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1017,3 +1017,35 @@ constraints or predicates) allowing @code{match} rules to be defined
 declaratively, to be used in other frameworks.  Typical scenarios include
 testing frameworks, mocking libraries and UI validation rules.")
     (license license:bsd-2)))
+
+(define-public java-junit
+  (package
+    (name "java-junit")
+    (version "4.12")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/junit-team/junit/"
+                                  "archive/r" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "090dn5v1vs0b3acyaqc0gjf6p8lmd2h24wfzsbq7sly6b214anws"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Delete bundled jar archives.
+                  (delete-file-recursively "lib")
+                  #t))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f ; no tests
+       #:jar-name "junit.jar"))
+    (inputs
+     `(("java-hamcrest-core" ,java-hamcrest-core)))
+    (home-page "http://junit.org/")
+    (synopsis "Test framework for Java")
+    (description
+     "JUnit is a simple framework to write repeatable tests for Java projects.
+JUnit provides assertions for testing expected results, test fixtures for
+sharing common test data, and test runners for running tests.")
+    (license license:epl1.0)))