summary refs log tree commit diff
path: root/gnu/packages/javascript.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 22:03:27 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-23 22:12:19 +0100
commitd3e6f41ad63e64c0fdfb9c24c2a9d1a2dd49b636 (patch)
tree4f7146927a3aa50271a8c343ccb36665bcf7fcff /gnu/packages/javascript.scm
parent41c3f10b4c68dc2007b512dfc239bdd76a7838c0 (diff)
downloadguix-d3e6f41ad63e64c0fdfb9c24c2a9d1a2dd49b636.tar.gz
gnu: mujs: Fetch sources from git.
* gnu/packages/javascript.scm (mujs)[source]: GIT-FETCH the sources
directly from the author.
[arguments]: Add VERSION to #:make-flags.
Diffstat (limited to 'gnu/packages/javascript.scm')
-rw-r--r--gnu/packages/javascript.scm28
1 files changed, 16 insertions, 12 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index 669951f741..48f3e85f77 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2017, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
@@ -416,23 +416,27 @@ external server.")
   (package
     (name "mujs")
     (version "1.0.7")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://mujs.com/downloads/mujs-"
-                                  version ".tar.xz"))
-              (sha256
-               (base32
-                "1ilhay15z4k7mlzs6g2d00snivin7vp72dfw5wwpmc0x70jr31l2"))))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ccxvii/mujs")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "08cm3w51xx1bznlglys9wl76vmbdf6jbd3cq504wzrqh10vgdfbv"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases
+     `(#:phases
        (modify-phases %standard-phases
-         (delete 'configure)  ; no configure
+         (delete 'configure)  ; no configure script
          (add-after 'install 'install-shared-library
            (lambda* (#:key (make-flags '()) #:allow-other-keys)
              (apply invoke "make" "install-shared" make-flags))))
-       #:make-flags (list (string-append "prefix=" (assoc-ref %outputs "out"))
-                          (string-append "CC=gcc"))
+       #:make-flags
+       (list ,(string-append "VERSION=" version)
+             (string-append "CC=gcc")
+             (string-append "prefix=" (assoc-ref %outputs "out")))
        #:tests? #f))                    ; no tests
     (inputs
      `(("readline" ,readline)))