summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-07-04 13:00:11 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-07-04 21:51:52 +0300
commit9cc167fe30b17153bbc99a5ae62bb12a9967c9f7 (patch)
tree0d9291301113b2c6d085233d31fc8b04fa4a1a2f /gnu/packages/julia-xyz.scm
parent9e63bafafbe7a7c2d9804fae62302ac8a7e90090 (diff)
downloadguix-9cc167fe30b17153bbc99a5ae62bb12a9967c9f7.tar.gz
gnu: Add julia-categoricalarrays.
* gnu/packages/julia-xyz.scm (julia-categoricalarrays): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 50effa43f4..4dad977d8d 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
 ;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
 ;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -394,6 +395,36 @@ can also be used to compute definite integrals by different numerical
 methods.")
     (license license:expat)))
 
+(define-public julia-categoricalarrays
+  (package
+    (name "julia-categoricalarrays")
+    (version "0.9.7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaData/CategoricalArrays.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1bcfylxdaizgasnmlkjjkf4dgfvy2y9ycnphw2d0z6mm9vx3n04x"))))
+    (build-system julia-build-system)
+    (native-inputs
+     `(("julia-pooledarrays" ,julia-pooledarrays)))
+    (propagated-inputs
+     `(("julia-dataapi" ,julia-dataapi)
+       ("julia-json" ,julia-json)
+       ("julia-json3" ,julia-json3)
+       ("julia-missings" ,julia-missings)
+       ("julia-recipesbase" ,julia-recipesbase)
+       ("julia-structtypes" ,julia-structtypes)))
+    (home-page "https://github.com/JuliaData/CategoricalArrays.jl")
+    (synopsis "Arrays for working with categorical data")
+    (description "This package provides tools for working with categorical
+variables, both with unordered (nominal variables) and ordered categories
+(ordinal variables), optionally with missing values.")
+    (license license:expat)))
+
 (define-public julia-chainrules
   (package
     (name "julia-chainrules")