summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSpencer King <spencer.king@geneoscopy.com>2024-09-05 19:17:02 +0000
committerLudovic Courtès <ludo@gnu.org>2024-09-25 16:17:14 +0200
commitad1664f8987f36c6efa0b2f82cc54e31cce38ede (patch)
tree2213d9e704c348790806f1204c491580efbbfb34 /gnu/packages/julia-xyz.scm
parentb7250a27b6bef021aba4ed5003d8b9dcf3d5530e (diff)
downloadguix-ad1664f8987f36c6efa0b2f82cc54e31cce38ede.tar.gz
gnu: Add julia-scientifictypesbase.
* gnu/packages/julia-xyz.scm (julia-scientifictypesbase): New variable.

Change-Id: I222d943bdbd94212064d4e620e497617aea68dc9
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9d11961674..12a5e87628 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -5633,6 +5633,34 @@ bytes in a chunk of memory.  Think of it like a much faster version of
     (supported-systems '("x86_64-linux"))
     (license license:expat)))
 
+(define-public julia-scientifictypesbase
+  (package
+    (name "julia-scientifictypesbase")
+    (version "3.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaAI/ScientificTypesBase.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1gkkyvighbwplbv3mcxdrall19zjsb9cwp0w2mr26sl6xbjxr8xc"))))
+    (build-system julia-build-system)
+    (native-inputs (list julia-tables))
+    (home-page "https://github.com/JuliaAI/ScientificTypesBase.jl")
+    (synopsis
+     "Base interface for dispatching on the 'scientific' type of data")
+    (description
+     "This package provides a Julia interface defining a collection
+of types (without instances) for implementing conventions about the scientific
+interpretation of data.  This package makes a distinction between the machine
+type and the scientific type of a Julia object.  A machine type refers to the
+Julia type being used to represent the object, for instance @code{Float64}.  The
+scientific type refers to how the object should be interpreted, for instance
+@code{Continuous} or @code{Multiclass{3}}.")
+    (license license:expat)))
+
 (define-public julia-scratch
   (package
     (name "julia-scratch")