summary refs log tree commit diff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-19 00:04:45 +0000
committerLudovic Courtès <ludo@gnu.org>2023-03-03 12:30:33 +0100
commitf808ce789da223311bc0416a593ecc1b6edb2248 (patch)
tree4d114b207db203c8f0dfa2df5816cd03c3e579f5 /gnu/packages/julia-xyz.scm
parente21c19b2ad62b3afc87fa85de85c7b649673d9f4 (diff)
downloadguix-f808ce789da223311bc0416a593ecc1b6edb2248.tar.gz
gnu: Add julia-optionaldata.
* gnu/packages/julia-xyz.scm (julia-optionaldata): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 0979f21664..0724977f39 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4284,6 +4284,29 @@ optimisation rules, and tools for applying them to deeply nested models.")
 JuliaNLSolvers packages.")
     (license license:expat)))
 
+(define-public julia-optionaldata
+  (package
+    (name "julia-optionaldata")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/helgee/OptionalData.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "11js258j7cz6362ijsi24nih3lx90aalf8k1n3fv6v7iqas8bz5s"))))
+    (build-system julia-build-system)
+    (home-page "https://github.com/helgee/OptionalData.jl")
+    (synopsis "Work with global data that might not be available")
+    (description
+     "This package provides the @code{@@OptionalData} macro and the corresponding
+OptData type which is a thin wrapper around a nullable value (of type @code{Union{T,
+Nothing} where T)}.  It allows you to load and access globally available data at
+runtime in a type-stable way.")
+    (license license:expat)))
+
 (define-public julia-orderedcollections
   (package
     (name "julia-orderedcollections")